l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2013 Mar 31 13:46

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Package file invalid error when installing androidapps
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Package file invalid error when installing androidapps

On Sun, Mar 31, 2013 at 11:11:40AM -0700, Alex Mandel wrote:
> On 03/31/2013 10:48 AM, Brian Lavender wrote:
> > On Sun, Mar 31, 2013 at 12:35:04AM -0700, Brian Lavender wrote:
> >> I keep getting the "Package File Invalid" error when I try to install apps
> >> on my android. I tried clearing caches and data, but I can not seem to
> >> get any apps to install. I have a Samsung R910 from Metro PCS with the
> >> Basix for R910.  I am attempting to install apps over wifi as I don't have
> >> service on this phone anymore.
> >>
> >> http://androidforums.com/indulge-all-things-root/381732-rom-r910-basix-1-0-aitos-revenge-speed-battery-smoothness-customizability-7-24-11-a.html
> >>
> >> Any tips?
> >
> > How do I get the apk package files for applications? I am thinking I can
> > just use adb to install them.
> >
> What method are you trying to use right now? Google Play?
> Wifi should not be a factor.
> I'm not sure there is an easy way to extract apk from the Google Play 
> webpages, it mostly should be about finding the url to grab the file.
> I can give you an apk to try side loading (need allow 3rd party app 
> installation enabled).
> http://www.wildlifecrossing.net/california/android

This phone has Google Market. Previously, when I reset the phone, it auto upgraded
to Google Play. It has not yet auto upgraded. Yet, I did give it my Google account
and when I log into Google Play website, I can see that it detected the phone.

I just tried "adb shell" and I can't even get a shell on the device. Usually, the shell
will work.

It looks like other problems as well. I turned on usb debugging and I
have used adb before, so I am pretty sure I am using adb correctly. Below
is the output I get:

[brian@localhost indulge.aio.v1.00]$ sudo ./adb shell
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
error: device not found

Brian Lavender

"There are two ways of constructing a software design. One way is to
make it so simple that there are obviously no deficiencies. And the other
way is to make it so complicated that there are no obvious deficiencies."

Professor C. A. R. Hoare
The 1980 Turing award lecture
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.