l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
January 6: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2011 Feb 15 11:54

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Apache: 2, Me: 0.
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Apache: 2, Me: 0.



On Tue, Feb 15, 2011 at 12:26 PM, Cam Ellison <cam@ellisonet.ca> wrote:
> On 11-02-15 08:56 AM, Peter Salzman wrote:
>>
>> OK, I commented out all the virtual host stuff and changed ports.conf to:
>>
>> Listen 80
>> <IfModule mod_ssl.c>
>>      # SSL name based virtual hosts are not yet supported, therefore no
>>      Listen 443
>> </IfModule>
>> ServerName dirac.org
>>
>> and Apache is still not responding to requests from outside my LAN.
>>
>> This is crazy!  I've never had so much trouble with this before.  The
>> packets are clearly coming in.  Could there be some kind of crazy
>> packet header rewriting to make the packets look like they're destined
>> for somewhere else (like the DSL modem)?
>>
>> Rod, do you have any other ideas?
> Maybe I missed something in this discussion, but it looks as though you
> have duplicate ServerName entries and Port assignments.  You can't do
> that - at least, not with impunity.  Use your sites-enabled file to
> specify the site and port(s), and take the corresponding entries out of
> apache.conf.  You also have conflicting site names between the two files.
>
> HTH
>
> Cam

Hi Cam!!!

When I take out the ServerName directive from apache2.conf and restart
the server, I get the following warning:

root@satan:/etc/apache2# /etc/init.d/apache2 restart

* Restarting web server
apache2: Could not reliably determine the server's fully qualified
domain name, using 127.0.0.1 for ServerName
 ... waiting apache2: Could not reliably determine the server's fully
qualified domain name, using 127.0.0.1 for ServerName   [ OK ]


I thought the ServerName within a virtual hosts directive indicates
which name that particular virtual host responds to but the general
ServerName is used (for some purpose) by the general web server?  I
tried taking the ServerName out of apache2.conf and got the error
message above.  Still didn't work, unfortunately,

Where is the ports assignment done twice?

I'm posting the relevant conf files.  Would be supremely grateful to
anyone who takes a look at them.  I'm really frustrated and humbled by
this problem.   :-(   :-(   dirac.org and iuselinux.org are both in
sites-enabled / sites-available.

Thank you!!
Pete

Attachment: apache2.conf
Description: Binary data

Attachment: dirac.org
Description: Binary data

Attachment: iuselinux.org
Description: Binary data

Attachment: ports.conf
Description: Binary data

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech


LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.