l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2010 Jun 13 23:45

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] boot failure with KDE
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] boot failure with KDE

Just to be painfully clear as to what I am doing:
(1) power on, hold down shift key
(2) highlight boot option, "Ubuntu, with Linux 2.6.32-22-generic
(recovery mode)" and press 'e' to edit the commands
(3) from the recovery menu, choose 'root' drop to root shell prompt
(4) I enter my root password and then run fsck /home, which gives the
following output:
# fsck /home
fsck from util-linux-ng 2.17.2
e2fsck 1.41.11  (14-Mar-2010)
fsck.ext2: Is a directory while trying to open /home

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the
superblock is corrupt, and you might try running e2fsck with an
alternate superblock: e2fsck –b 8193 <device>

I am not sure that this is relevant, but my /dev/sda1 is type ext4


On Sun, Jun 13, 2010 at 11:20 PM, Tony Cratz <cratz@hematite.com> wrote:
> On 06/13/2010 11:14 PM, Thomas Johnston wrote:
>> Tony,
>> Thanks for the reply.  I'm sorry, but I am not a very sophisticated
>> Linux user.  Could you be a little detailed with your answers?
>> I have tried to Google how to boot in single user mode without much
>> luck.  So far I have found two things:
>> (1) one website calls changing the run level to 1 entering 'single user' mode
>> (2) a second says to hold down the "shift" key at beginning of the
>> boot sequence.  I tried this and was presented with the option to boot
>> several different kernels (and each kernel had a recovery mode
>> option).  At the bottom of the screen it sasy: "Press enter to boot
>> the selected OS, 'e' to edit the commands before booting or 'c' for a
>> command-line."  If I highlight the latest kernel (Ubuntu, with Linux
>> 2.6.32-22-generic (recovery mode) and press 'e', I get several more
>> options, one of which is: linux /boot/vmlinuz-2.6.32.-22-generic
>> root=UUID=long alpha-numeric string ro single.  I highlighted this
>> option and pressed "ctrl-x" to boot it.  I then get a recovery menu
>> which has various options: resume, clean, dpkg, failsafeX, grub,
>> netroot, root
>> I am in the ballpark of what you were suggesting I do?
>        Yes you are in the ball park. Please see yesterday E-mail to Hai
>        Yi about going into Grub and then 'drop to root shell'.
>        With most versions of *nix you can get into the single user
>        mode during the boot up procedure. *buntu has made it easy
>        with Grub and the 'Recover' mode.
>        Once you are in single user mode (root) then you should do
>        an 'fsck /home' to insure the partition is clean. Once it is
>        it should then be able to be mounted as read/write (which is
>        the error you where having).
>                                                        Tony
> _______________________________________________
> vox-tech mailing list
> vox-tech@lists.lugod.org
> http://lists.lugod.org/mailman/listinfo/vox-tech
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!