l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
September 2: Social gathering
Next Installfest:
TBD
Latest News:
Aug. 18: Discounts to "Velocity" in NY; come to tonight's "Photography" talk
Page last updated:
2010 Jun 01 21:42

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] how to find the self-installed libs?
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] how to find the self-installed libs?



Thanks to all for the helpful suggestions!

This is what I've done since after:

1. I haven't figured out how checkinstall works, retry later...
2. tried to run ffmpeg's configure again, with two addtional options "
--libdir=/usr/local/lib --incdir=/usr/local/include " (options can be
found from ./configure --help), the issue persists:

hai@zodiac:~/ffmpeg$ ./configure --mandir=/usr/local/ffmpeg/share/man
--libdir=/usr/local/lib --incdir=/usr/local/include --enable-gpl
--enable-nonfree --enable-avfilter --enable-x11grab --enable-libfaac
--enable-libfaad --enable-libfaadbin --enable-libgsm
--enable-libtheora --enable-libx264 --enable-libxvid --enable-zlib
ERROR: libx264 not found

libx264.a is in /usr/local/lib;
x264.h is in /usr/local/include



On Tue, Jun 1, 2010 at 1:33 AM, Brian Lavender <brian@brie.com> wrote:
> You may have already solved the problem, but here are some extra notes
> to confuse^H^H^H^H^H help in the matter. P-)
>
> I believe that sometimes you can set the environment variable (below), if for
> some reason it doesn't have a configure option to search in /usr/local
> like the --include option Alex mentioned below.
>
> export CFLAGS="-I/usr/local/include"
>
> export LDFLAGS="-L/usr/local/lib"
>
> This will help the configure script find your library. These
> flags will be passed and used in the compile.
>
> When you run your program, you may have to set the LD_LIBRARY_PATH
> variable.
>
> export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
>
> Just a word of caution. If you you installed libx264 under the Debian
> package management system, and then you grabbed a more recent version
> elsewhere, you will want to check that your executable is not grabbing
> the one installed through package management. You can check this using
> the command
>
> ldd myexecutable
>
> Here is a good tutorial. It's mostly for creating your own libraries,
> but if you are the hacker type ( I assume that you are ), it will
> provide useful insight.
>
> http://www.yolinux.com/TUTORIALS/LibraryArchives-StaticAndDynamic.html
>
>
> brian
>
>
>
> On Mon, May 31, 2010 at 11:58:56AM -0700, Alex Mandel wrote:
>> On 05/31/2010 09:58 AM, Hai Yi wrote:
>> > Hello All:
>> >
>> > i've downloaded and installed libx264 from web since the one with
>> > ubuntu (9.10) is lower in version. I can see that lib has been
>> > installed on /usr/local/lib:
>> >
>> > hai@zodiac:~/downloads/x264$ ls -ltr /usr/local/lib/libx264*
>> > -rw-r--r-- 1 root root 993618 2010-05-31 12:50 /usr/local/lib/libx264.a
>> >
>> > However it seems that it is NOT picked up by ffmpeg configuration:
>> >
>> > hai@zodiac:~/ffmpeg$ ./configure --mandir=/usr/local/ffmpeg/share/man
>> > --enable-gpl --enable-nonfree --enable-avfilter --enable-x11grab
>> > --enable-libfaac --enable-libfaad --enable-libfaadbin --enable-libgsm
>> > --enable-libtheora --enable-libx264 --enable-libxvid --enable-zlib
>> > ERROR: libx264 not found
>> >
>> >
>> > nor shown when using
>> >
>> > dpkg --get-selections | grep libx264
>> >
>> >
>> > How can I do to make this lib awared to the system?
>> >
>> > Thanks,
>> > Hai
>>
>> Some options:
>> 1. When compiling yourself on a Debian based system use checkinstall
>> where possible. This creates a local deb file and installs via the
>> package manager.
>>
>> 2.In you particular case /usr/local/lib just isn't in the normal path.
>> You can either add it to the path via a command line statement or using
>> the ldconfig system, OR you can specifiy directories to be included in
>> the ffmpeg build process. It's usually something like
>> --include=/usr/local/lib/ but check the docs of configure and the ffmpeg
>> package.
>>
>> Alex
>> _______________________________________________
>> vox-tech mailing list
>> vox-tech@lists.lugod.org
>> http://lists.lugod.org/mailman/listinfo/vox-tech
>
> --
> Brian Lavender
> http://www.brie.com/brian/
>
> "There are two ways of constructing a software design. One way is to
> make it so simple that there are obviously no deficiencies. And the other
> way is to make it so complicated that there are no obvious deficiencies."
>
> Professor C. A. R. Hoare
> The 1980 Turing award lecture
> _______________________________________________
> vox-tech mailing list
> vox-tech@lists.lugod.org
> http://lists.lugod.org/mailman/listinfo/vox-tech
>
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.