l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2010 Mar 01 15:33

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] [netCDF #QCY-964177]: netcdf - 4.0.1 problems
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] [netCDF #QCY-964177]: netcdf - 4.0.1 problems

how do I enable the "universe" repository?

On Mon, Mar 1, 2010 at 3:24 PM, Carl Boettiger <cboettig@gmail.com> wrote:
You shouldn't have to configure using sudo if the netcdf file is in your home directory, which it looks like it is, since it is on your desktop.  You should have write access to that as an ordinary user.  That said, no running it with sudo shouldn't hurt -- presumably that command worked without error and hence you have root access?

The next command is usually make, sudo make install being third (just putting it into the binaries).  That is, the command sequence is usually.

sudo make install

All from the directory you specify.  This compiles the package from source, which can be tricky to get to work.  You mentioned you are on ubuntu.  Have you tried simply issuing:

sudo apt-get install netcdf-bin

at the command-line instead?  That should install the software, automatically resolve dependencies you might be missing, and be easier to keep it up to date.

If that doesn't find anything, try enabling the "universe" repository

On Mon, Mar 1, 2010 at 3:18 PM, Jason Snyder <jmssnyder@ucdavis.edu> wrote:
I did configure and install netcdf as you specified  using sudo:


sudo ./configure
sudo make install

I also did make check and everything seems all right based on make check.

is it because of lack of write access that I have for the directory /home/snyderjm/Desktop/netcdf-4.0.1?

How do I obtain access to /usr/local?

Also how do I access root directory since i have permission denied here.

On Mon, Mar 1, 2010 at 2:31 PM, Unidata netCDF Support <support-netcdf@unidata.ucar.edu> wrote:
The problem almost certainly is that you do not have
access to /usr/local.
You will need to do one of two things.
1. configure and install netcdf using sudo or logged in as root.
2. choose a different location to install netcdf; one for which you
  have write access. You specify that by saying
  ./configure -prefix=<path to install directory>

=Dennis Heimbigner

Ticket Details
Ticket ID: QCY-964177
Department: Support netCDF
Priority: Normal
Status: Open

vox-tech mailing list

Carl Boettiger
Population Biology, UC Davis

vox-tech mailing list

vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.