l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
April 21: Google Glass
Next Installfest:
TBD
Latest News:
Mar. 18: Google Glass at LUGOD's April meeting
Page last updated:
2010 Jan 13 23:33

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] apt-get problem
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] apt-get problem



Norm Matloff wrote:
> In my description of the apt-get problems that arose when I installed
> the latest version of R, 2.10.0, I had one aspect incorrect:  I did not
> use apt-get to download 2.10.0; that would have just gotten me version
> 2.6.2, which I already had and which did not have crucial features.
> Instead, I went to the R Web page and downloaded a .deb file for Hardy
> Heron (Ubuntu 8.04, my OS).  I then used gdebi to install it, getting a
> warning message about "inconsistencies," as I wrote yesterday, after
> which I could not use apt-get to download any other stuff, e.g. mplayer.
> R itself worked fine.  Sorry for the misunderstanding.
> 
> Following some of the suggestions here, this evening I used the Update
> Manager to update all packages.  That restored the old R, 2.6.2, which
> is the latest version of R among my repositories (which are the ones
> that came with the system, no additions by me).  So it didn't help.
> 
> I then downloaded R from the R Web page again, by this time version
> 2.10.1.  Interestingly, gdebi didn't give me an error message, but again
> apt-get refused to download anything else afterward, citing
> inconsistencies.  Synaptic Package Manager would not even come up;
> instead, a little window came up saying "You have 12 broken packages on
> your system!  Use the 'Broken' filter to locate them."  Naturally, I
> declined.
> 
> I then followed the suggestion to use aptitude.  This turned out to
> solve my problem, as it organized the information better (especially
> from my point of view, as I don't know all the ins and outs of apt-get
> etc.).  Some of the information there pointed to the r-recommended
> package being for 2.6.2.  So I removed that using aptitude.
> 
> Well, of course, then R didn't work at all.  It was missing a library.
> So, I ran gdebi again to re-reinstalled R, hoping that that would pick
> up the libraries etc., and it worked!  R works fine, and I was able to
> download mplayer.  Still odd that apt-get had blocked me from adding
> mplayer just because of r-recommended.
> 
> Thanks for the help, everyone.  The suggestion to use aptitude was quite
> valuable; in retrospect, of course, I should have thought of the
> r-recommended problem, but aptitude really helped me zero in on it.
> All the other comments at least clarified things for me, and thus were
> valuable too.
> 
> Norm
> 

Keep in mind one should either use aptitude or apt, and be careful not
to mix them. They track packages differently and have the potential to
clobber each other.

As for R installs, the magic for me is to add the R repos for Ubuntu, so
that apt-get just works. See http://cran.r-project.org/bin/linux/ubuntu/
This helps to always keep me up to date, although only some packages are
in the repos and for others I still do install.packages in R itself.

Alex

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.