l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2009 Nov 23 15:29

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Wired & Wireless connection problems - Jaunty KDE4.3
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Wired & Wireless connection problems - Jaunty KDE4.3

OK. So I figured it out.  It turns out that my networking issues had
nothing to do with the KDE upgrade.  On the same day I upgraded KDE,
my labmate put his personal wireless router in the lab.  I tried
establishing a manual connection as Eric suggested and noticed that I
was getting DHCPNAK message.  After quite a bit of time on Google
looking for DHCPNAK and what it meant, I found a forum post saying
that there was a known bug with certain routers causing them to reject
connections from computers with names greater than 15 characters.  I
changed my computer name and presto! The interwebs were restored!
Sweet.  For now at least ... let's see what else goes wrong.

Thanks Eric!

On Wed, Nov 18, 2009 at 7:40 PM, Eric Lin <notapplicable.haha@gmail.com> wrote:
> On Wed, Nov 18, 2009 at 03:10:28PM -0800, Thomas Johnston wrote:
>> But, my labmate has a live CD of karmic koala.  I booted that (making
>> no permanent changes to my computer) and the wired connection worked
>> immediately.  However, no wireless connections were available.  Via
>> the wired connection I downloaded & activated the recommended STA
>> driver for my wireless adapter and then was able to connect to both
>> moobilenet and the unencrypted wireless AP my labmate has running in
>> our lab.  (I couldn't connect to moobilenetx, but if I played around
>> with the settings I could probably get that working, too).
> In that case, it might be a configuration problem for the wired
> connection. You have the same ethernet card I do, and you're using the
> same modules for it. It could be wicd's improperly configuring
> /etc/network/interfaces. See if you can get connected manually by dhcp:
> sudo ifconfig eth0 down
> sudo ifconfig eth0 up
> sudo dhclient eth0 (or sudo dhcpcd eth0)
> If that doesn't work, try using a static IP address. You'll have to
> deduce one from one of your labmates(?) wired IP addresses (or the one
> you get in Ubuntu 9.10):
> sudo ifconfig eth0 abc.def.ghi.jkl broadcast abc.def.ghi.255 \
> netmask
> sudo route add default gw mno.pqr.stu.vwx eth0
> sudo bash -c "echo -e \"nameserver\\nnameserver \
>\" > /etc/resolv.conf"
> and are the OpenDNS nameservers.
> Replace abc.def.ghi.jkl with your desired IP address, abc.def.ghi.255
> with your desired broadcast address, with your desired
> netmask address, and mno.pqr.stu.vwx with your gateway address. Example:
> If abc.def.ghi.jkl is,
> abc.def.ghi.jkl could be,
> could be, and
> mno.pqr.stu.vwx could be
> Have you "apt-get remove --purge"d knetworkmanager and network-manager,
> by the way? That should ensure that there won't be conflicts between
> knetworkmanager and wicd.
> -Eric
> _______________________________________________
> vox-tech mailing list
> vox-tech@lists.lugod.org
> http://lists.lugod.org/mailman/listinfo/vox-tech
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.