l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2006 Jun 06 15:34

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Hard Drive Partitioning Errors
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Hard Drive Partitioning Errors

running a dd will give you a simple sector read test.  Looks like, at a
minimum, you've got a bad sector 2, which means, yes, the drive is gone.
If you it's an ide drive (looks like it), and you know or can figure out
how to rewrite the firmware bad sector table, you could conceivably make
the drive servicable again...  assuming there's only a few sectors bad.
And yes, a friend did this for me one time on a similar issue.

On Tue, Jun 06, 2006 at 10:32:26AM -0700, Richard Crawford wrote:
> I've taken that bad HD out of my computer and I'm messing around with it now.  
> There's nothing critical on the disk, so I'm attempting to run some tests and 
> see if anything can be done with it.
> Executing:
> $ sudo e2fsck -c /dev/hdb
> yields this:
> e2fsck: Attempt to read block from filesystem resulted in short read while 
> trying to open /dev/hdb
> Could this be a zero-length partition?
> I tried:
> $ sudo parted -i /dev/hdb mklabel msdos
> which resulted in:
> Error: Input/output error during read on /dev/hdb
> Retry/Ignore/Cancel?   
> >From what little I can figure, I can't really do much with this hard drive 
> unless it has a partition table.
> Just for kicks, I also tried:
> $ mke2fs -S /dev/hdb
> which gave me these errors:
> Warning: could not erase sector 2: Attempt to write block from filesystem 
> resulted in short write
> and
> Warning, had trouble writing out superblocks.done
> I also tried
> $ mke2fs -c /dev/hdb
> which returned no errors, but e2fsck still bombed with the same error message.
> As far as I can tell, this HD is perfectly pooched. I should point out that I 
> don't really know what I'm doing, just grasping at straws and doing searches 
> on Google for each error message that comes up.  Is there a better way of 
> doing this sort of thing and actually fixing the hard drive? Or is it hosed 
> for good?

Ted Deppner
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!