l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2006 May 12 22:30

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Hosed hard drive?
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Hosed hard drive?

Richard Crawford wrote:
Running Kubuntu Dapper flight 6 on dual-core PIII. The hard drive is 120 GB.
This evening, while working on this computer, it started telling me that my filesystem was read-only. I rebooted, and the system got as far as checking the root filesystem, whereupon it gives me the following error:

(i.e., without -a or -p options)

When I execute fsck...

root@seamus: fsck
fsck 1.38 (30-Jun-2005)
e2fsck 1.38 (30-Jun-2005)
fsck.ext3: No such file or directory while trying to open /dev/mapper/Ubuntu-root

The superblock could not be read or does not contain a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

So I tried...

# e2fsck -b 8193 /dev/hda

and got the same message. I also tried 16384 and 32768 (based on the information from man e2fsck -- I honestly don't know the blocksize on my filesystem).

dmesg shows nothing useful. However, syslog has the following entries from just before the system crashed:
May 11 18:12:44 seamus kernel: [4478515.955000] ppdev: user-space parallel port driver
May 11 18:13:05 seamus kernel: [4478537.620000] hda: task_in_intr: status=0x49 { DriveReady DataRequest Error }
May 11 18:13:05 seamus kernel: [4478537.620000] hda: task_in_intr: error=0x04 { DriveStatusError }
May 11 18:13:08 seamus kernel: [4478537.620000] ide: failed opcode was: uknown

What's really annoying is that the computer has suddenly decided it will no longer boot from the CD-ROM drive, even though I have the BIOS set to boot from CD-ROM, then the hard drive. Thus, I can't boot from the installation media to attempt a system rescue there. I've tried booting using recovery mode from GRUB, but I only get the same issues.

Any thoughts? This is a fairly old computer (five years old) so I guess all manner of horrors, including a failed motherboard, are possible.

Got a floppy on that, try a Smart Boot Disk to get the CD to boot.

I'd also recommend if you have the hardware, put the drive into another machine as a 2nd drive and run more in depth tools from a working OS.
Maybe try to read the S.M.A.R.T status too (if the drive has that).

Hopefully that'll get you started - Alex
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.