l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2005 Nov 30 21:49

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] KDE on FreeBSD Hanging on login
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] KDE on FreeBSD Hanging on login

On Nov 30, 2005, at 7:19 PM, Jeffrey J. Nonken wrote:

On Wed, 30 Nov 2005 00:01:36 -0800, Bill Kendrick wrote:
On Tue, Nov 29, 2005 at 08:26:06PM -0800, Michael Benedetti wrote:

I am a newbie to FreeBSD.
Me too, but I've done some of this lately, so it's fresh on my mind.
Not to mention fresh in my bookmarks. :)
I managed to get the install to work after
three tries, and even configured it to boot directly to the KDE
boot manager, where I can login.  I have a few minor issues,
beginning with the inability to login using the KDE boot manager.
 This behavior started as soon as I tried to use the KDE boot
manager to start Gnome. (I wanted to automount the cd drives, and
read that Gnome does this by default, while I was not able to
accomplish this in KDE.  I am getting an error whenever I try to
mount the CD in KDE.)

The Console Login seems to be inoperative.

As in text-mode?  (Under Linux, typically accessed via
Ctrl+Alt+F1..F6, etc.)

Bill and Jeffrey,

Ctrl+Alt+F3 worked! It seems the trouble was my (only) user was hosed up. After removing and adding the user, everything seems ok. Thank you both for your help! I think with the help of nice lugod folks like you I'll be able to avoid going back to XP, and that is my goal.

Thanks again for your help!


IIRC KDM gives you the option to choose your window manager, shut
down, or log into a console (terminal emulator) session. Sounds like
the terminal emulator isn't working either.

Michael, early in the boot process you should see a text menu come up
with something like an 8 second timeout. There will be an ASCII art
BSD Demon on the right. If you hit "3" before it times out it should
put you to a failsafe session, which I HOPE would not get you into
KDM. If that doesn't work, try again with "4". If that doesn't work,
boot off a bloody Knoppix or FreeSBIE CD and you'll be able to access
everything as a mounted data drive. Or...
If you're on a network, it should also be possible to login
remotely, to see what's going on.
...another good suggestion. What you need is a command prompt and a
text editor, or whatever nice GUI editor Knoppix gives you, or some
such. That, and root access.

The first step I'd take would be to disable KDM, log in on the command
line, and type "startx" to see if you can log into X at all. Here's
how we do that:

Get into your command prompt (discussed above) and login as your
regular user. If you can't do that (you went through Knoppix or
something) cd /home/username relative to the mount point. Remove or
rename the file called .xinitrc. That will stop you trying to log into
a window manager.

Then you need to edit /etc/ttys (again relative to the mount point, if
on a live CD). This is where you need root access. You'll find a line
similar to this:

ttyv8   "/usr/X11R6/bin/xdm -nodaemon"  xterm   off secure

...only it'll have the kdm manager and it'll say "on". You need to
change "on" to "off" and save it. [Ref:

Reboot, it should get you to a command prompt this time. I don't know
if you're new to *nix so I won't go into detail about getting X
running, but you need to do that. The handbook has more details than I
can cover anyway:

That wraps on my screen, that should end with "html". Not gonna turn
wrapping off for that, though. Use this instead if you like:

Once you have X working, try running KDE as a window manager without
using a display manager. Log in as your user and enter the following:

echo "exec startkde" > ~/.xinitrc


Then type "startx" and it should come up in KDE. If it is, you're
golden, at least as regards KDE.

Go back and fix that line in /etc/ttys, reboot, and see if KDM will
let you log in now. If not... I don't know where to go from there, but
you'll have verified that X itself works, and KDE works, and now you
know how to enable and disable KDM.

vox-tech mailing list

vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.