l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 24: LUGOD election season has begun!
Page last updated:
2005 Oct 16 15:57

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] CUPS on FreeBSD
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] CUPS on FreeBSD



On Wed, 12 Oct 2005 19:32:48 -0700, Jeff Newmiller wrote:
> CUPS emulates lpd.  The instructions you said you had followed
> pointed out that you would have to mv the lpd commands in /usr/bin
> so that the CUPS equivalents from /usr/local/bin would get invoked
> instead from later in the PATH.

True, though that didn't eliminate lpd itself. But I was told the same
thing yesterday on IRC, so I've killed off lpd and removed it from
rc.conf. That may have been interfering. (I'd already renamed the
related lpd commands.)

At this point I've got it responding to shell commands and the web
interface.

. . . .

After a lot of description of further problems, I started explaining
that localhost isn't responding. Then I started fiddling, and ended up
throwing out all I'd said, because I seem to have fixed it.

ifconfig showed lo0 without a configuration:

aphrodite# ping Localhost
PING localhost.wyndow.reality (127.0.0.1): 56 data bytes
ping: sendto: Can't assign requested address
ping: sendto: Can't assign requested address
ping: sendto: Can't assign requested address
ping: sendto: Can't assign requested address
^C
--- localhost.wyndow.reality ping statistics ---
4 packets transmitted, 0 packets received, 100% packet loss
aphrodite# ifconfig
fxp0: <snip>
plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
lo0: flags=8008<LOOPBACK,MULTICAST> mtu 16384

Not knowing what else to do, figuring I had nothing to lose, I
configured it:

aphrodite# ifconfig lo0 127.0.0.1 netmask 255.255.255.0
aphrodite# ifconfig
fxp0: <snip>
plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
        inet 127.0.0.1 netmask 0xffffff00
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
aphrodite# ping localhost
PING localhost.wyndow.reality (127.0.0.1): 56 data bytes
64 bytes from 127.0.0.1: icmp_seq=0 ttl=64 time=0.114 ms

Now it seems to be responding. I've reverted cupsd.conf and
client.conf back to using localhost, now the CUPS GUI configurator
seems to be more-or-less working, and so on.

I have a feeling this is related to other problems that have cropped
up. Seems to have happened after I used Webmin to switch from DHCP to
fixed IP. Since then I had rediscovered my notes and polished the
config, except for configuring lo0 (which I've never had to do before,
ever, that I can recall, on Solaris SPARC or Slackware or Mandrake or
NetBSD or prior FreeBSD installs, so forgive me if I missed the
obvious).

The CUPS web interface is now working, as is the CUPS GUI
administrator. I can pop back and forth and get the same results.

Unfortunately, one of the results is that the printer isn't printing.

And NOW I feel that I've gotten enough other problems resolved to pass
along my CUPS configuration files.

First, a couple screenshots:

http://jnork.nonken.net/images/Misc/PRINT-1.GIF
http://jnork.nonken.net/images/Misc/PRINT-2.GIF

I got the same results whether I tried to connect via USB or JetPrint.
For now I've set it to /dev/ulpt0 to reduce the number of variables.

And just to make sure, I just did

lptest 79 1 > /dev/ulpt0

and sure enough, the printer responded.

http://jnork.nonken.net/images/Misc/CUPS/

error_log.txt (I had to give it an extention so you could access it)
contains very little, actually. I left the CUPS GUI configurator
running, stopped cupsd, renamed the old error_log, started cupsd, and
tried printing a test page. That's pretty much all that's in there,
but at log level debug2 it's a very VERBOSE not-very-much.

But it's all there, if anybody has any idea what to look for.

I will be pouring over the CUPS documentation later, but now I'm going
to try to catch the second half of the installfest, if there's any
left. At least the exercise will be good for me.


_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!