l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2005 May 08 13:06

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] browser and mimetypes (I think)
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] browser and mimetypes (I think)

On Sun 08 May 05, 12:20 PM, Troy Arnold <troy-vox@zenux.net> said:
> On Sun, May 08, 2005 at 10:56:54AM -0400, Peter Jay Salzman wrote:
> > There's an URL to a pdf download of an article published by Optics Letters.
> > I don't think anyone can access this because I'm using a Princeton
> > University proxy (and Princeton has a subscription to this journal), but the
> > URL is:
> > 
> >    http://ol.osa.org/ViewMedia.cfm?id=68550&seq=0
> > 
> > It doesn't look like a pdf.  I tried and tried to get the pdf to download
> > and display on Firefox on Linux.  I think perhaps it downloads OK but
> > Firefox doesn't know what to do with it, since it's a "cfm" file, whatever
> > that is, not a pdf file.
> 'cfm' probably means it's a Cold Fusion document,

Aha.  OK.  Coldfusion is kind of like PHP/ASP?  Client side stuff?

> but that's irrelevant
> to your problem, I think.  The problem likely lies with what
> content-type headers the document is spitting out before it delivers the
> actual pdf.
> A couple of things to try:
> 1) HEAD the document and see what headers are being sent.  Then, fiddle
>    with Firefox until it does "the right thing" when it see's those
>    headers.  In Debian, HEAD is part of Perl's LWP package (libwww-perl)
>    As an aside, it includes other handy tools such as, GET and POST.
> 2) Check your browser cache for an appropriately sized file and
>    mv/rename it to .pdf.  Note, that there may be extraneous stuff
>    before the actual pdf data.  The PDF's I've looked at all start with
>    the string "%PDF-n.n" where 'n' appears to be a version number.
> 2) try something like wget or curl and see if they're able to download
>    the document directly.
> Hope that at least provides some ideas for you to try.
Awesome suggestions!  #2 looked easiest, so I tried it.

Turns out FF was not displaying _any_ pdf documents.  I dunno how I survived
so long without discovering this.  Guess I use ps more.

Anyhow, now that I know the problem isn't some wierd proxy thing but a
tangible and simple "I can't view pdf", I did a Google search.

I disabled the pdf plugin for FF and instead had FF use a helper function
(xpdf) view the file, and it worked.  I hate viewing stuff in a browser
window anyhow.  You get a smaller viewing rectangle.  :)

Thanks guys!


Every theory is killed sooner or later, but if the theory has good in it,
that good is embodied and continued in the next theory. -- Albert Einstein

GPG Fingerprint: B9F1 6CF3 47C4 7CD8 D33E  70A9 A3B9 1945 67EA 951D
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.