l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
April 21: Google Glass
Next Installfest:
TBD
Latest News:
Mar. 18: Google Glass at LUGOD's April meeting
Page last updated:
2005 Apr 28 21:29

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Wine on amd64 for 32bit win
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Wine on amd64 for 32bit win



Hmm. It appears that after a reboot this line did work
/dev/sda1 /Windows ntfs ro,defaults,umask=0000 0 0

but how do I 'bind' that to my chroot so wineinstall sees it?

/etc/fstab currently has this:
/home /chroot/home none bind 0 0
/tmp /chroot/tmp none bind 0 0
/dev /chroot/dev none bind 0 0
/proc /chroot/proc proc defaults 0 0
/media/cdrom0 /chroot/media/cdrom0 none bind 0 0

If I open up fstab in the chroot it's blank, should I be adding a mount here?
When I tried that it told me th line was bad.

Thanks,
Alex

Ken Bloom wrote:
 by mx.perfora.net[172.19.34.100] (Nemesis),

 id 0MKuxu-1DRAMP2sMv-00008b for tech_dev@wildintellect.com
Received: from ns1.livepenguin.com (localhost [127.0.0.1])
	by www.livepenguin.com (Postfix) with ESMTP id 28625C2624;
	Thu, 28 Apr 2005 07:51:17 -0700 (PDT)
X-Original-To: vox-tech@lists.lugod.org
Delivered-To: vox-tech@livepenguin.com
Received: from velocipede.dcn.davis.ca.us (velocipede.dcn.davis.ca.us
	[168.150.193.10])
	by www.livepenguin.com (Postfix) with ESMTP id BA21C76834
	for <vox-tech@lists.lugod.org>; Thu, 28 Apr 2005 07:51:12 -0700 (PDT)
Received: from localhost (dcn239-115.dcn.davis.ca.us [168.150.239.115])
	by velocipede.dcn.davis.ca.us (8.12.10/8.12.10/Omsoft) with ESMTP id
	j3SEp7KG010510
	for <vox-tech@lists.lugod.org>; Thu, 28 Apr 2005 07:51:07 -0700 (PDT)
Received: from [127.0.0.1] (localhost [127.0.0.1])
	by localhost (Postfix) with ESMTP id 2F43DE2403
	for <vox-tech@lists.lugod.org>; Thu, 28 Apr 2005 07:51:05 -0700 (PDT)
Message-ID: <4270F852.1010308@ucdavis.edu>
Date: Thu, 28 Apr 2005 07:50:58 -0700
From: Ken Bloom <kabloom@ucdavis.edu>
User-Agent: Debian Thunderbird 1.0.2 (X11/20050331)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: "lugod's technical discussion forum" <vox-tech@lists.lugod.org>
Subject: Re: [vox-tech] Wine on amd64 for 32bit win
References: <426F275F.6000103@wildintellect.com>
	<42706950.2000906@wildintellect.com>
In-Reply-To: <42706950.2000906@wildintellect.com>
X-Enigmail-Version: 0.91.0.0
X-Spam-Level: (0)
X-Scanned-By: mimedefang on mail.omsoft.com
X-BeenThere: vox-tech@lists.lugod.org
X-Mailman-Version: 2.1.5
Precedence: list
Reply-To: lugod's technical discussion forum <vox-tech@lists.lugod.org>
List-Id: lugod's technical discussion forum <vox-tech.lists.lugod.org>
List-Unsubscribe: <http://lists.lugod.org/mailman/listinfo/vox-tech>,
	<mailto:vox-tech-request@lists.lugod.org?subject=unsubscribe>
List-Archive: <http://ns1.livepenguin.com/pipermail/vox-tech>
List-Post: <mailto:vox-tech@lists.lugod.org>
List-Help: <mailto:vox-tech-request@lists.lugod.org?subject=help>
List-Subscribe: <http://lists.lugod.org/mailman/listinfo/vox-tech>,
	<mailto:vox-tech-request@lists.lugod.org?subject=subscribe>
Content-Type: multipart/mixed; boundary="===============0748230476=="
Sender: vox-tech-bounces@lists.lugod.org
Errors-To: vox-tech-bounces@lists.lugod.org
Envelope-To: tech_dev@wildintellect.com

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--===============0748230476==
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature";
	boundary="------------enig2C92D939708D03A553120D8F"

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig2C92D939708D03A553120D8F
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

Alex Mandel wrote:

So after browsing some literature I decided I needed to install a
chroot(http://ubuntuforums.org/showthread.php?t=24575) to run wine
inside of, that way I could use i386 packages.

That part went fine. Now I'm trying to configure wine and it's
complaining that it can't find my windows partition. Now that makes
sense, since I haven't mounted it yet.

So I tried to mount my windows NTFS partition in  (etc/fstab):
/dev/sda1       /Windows        ntfs    umask=0222   0       0

and it works, except I can't open the partition, permission denied.
I've toggled the settings a few times and sudo mount -a after each but
always the same result.

What do you get if you run `ls -ld' on the mountpoint (when the drive is
mounted). I'm guessing that you're running kernel 2.6 where the umask
and showexec options have been replaced by fmask and dmask (for files
and directories respectively).

--Ken Bloom

--
I usually have a GPG digital signature included as an attachment.
See http://www.gnupg.org/ for info about these digital signatures.

--------------enig2C92D939708D03A553120D8F
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFCcPhXlHapveKyytERAnC6AKCZ+XwCM1abSMNdGwfcXn0hK6dm/gCePq+L
Lv2DnNbkYZmIeH4neA12x6c=
=Ppul
-----END PGP SIGNATURE-----

--------------enig2C92D939708D03A553120D8F--

--===============0748230476==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech

--===============0748230476==--
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.