l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
April 21: Google Glass
Next Installfest:
TBD
Latest News:
Mar. 18: Google Glass at LUGOD's April meeting
Page last updated:
2005 Jan 24 13:54

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] parport troubles
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] parport troubles



Hi all,

Kernel 2.6.9 has been giving me parport woes.  My printer works on all my
kernels, except 2.6.9.  Under every kernel *except* for 2.6.9:

   * IRQ7 is assigned to parport
   * The printer works.

On the 2.6.9 kernel:

   * parport is not assigned an IRQ.
   * The printer doesn't work (duh).

Here's a comparison of kernel config options related to parport:

2.6.9 config options (where           2.6.7 config options (where
parport is broken)                    parport works)
=============================         =================================
CONFIG_PARPORT=y                      CONFIG_PARPORT=y
CONFIG_PARPORT_PC=y                   CONFIG_PARPORT_PC=y
CONFIG_PARPORT_PC_CML1=y              CONFIG_PARPORT_PC_CML1=y
# CONFIG_PARPORT_SERIAL is not set    # CONFIG_PARPORT_SERIAL is not set
CONFIG_PARPORT_PC_FIFO=y              CONFIG_PARPORT_PC_FIFO=y
CONFIG_PARPORT_PC_SUPERIO=y           CONFIG_PARPORT_PC_SUPERIO=y
CONFIG_PARPORT_OTHER=y                CONFIG_PARPORT_OTHER=y
CONFIG_PARPORT_1284=y                 CONFIG_PARPORT_1284=y

   
On 2.6.9, dmesg has some mysterious messages:

   pnp: the driver 'parport_pc' has been registered
   pnp: match found with the PnP device '00:0e' and the driver 'parport_pc'
   parport: PnPBIOS parport detected.
   pnp: Device 00:0e disabled.

which explains a lot without really explaining anything.  I have no idea why
the device is disabled only under 2.6.9.  The only thing I knew what to do
was to compare config options related to pnp, since that is what presumably
disabled the parport device:


2.6.7 (works)                          2.6.9 (doesn't work)
=============                          ====================
# Plug and Play support                # Plug and Play support
#                                      #
CONFIG_PNP=y                           CONFIG_PNP=y
CONFIG_PNP_DEBUG=y                     CONFIG_PNP_DEBUG=y
                                       
# Protocols                            # Protocols
#                                      #
CONFIG_ISAPNP=y                        CONFIG_ISAPNP=y
CONFIG_PNPBIOS=y                       CONFIG_PNPBIOS=y
# CONFIG_PNPBIOS_PROC_FS is not set    # CONFIG_PNPBIOS_PROC_FS is not set


I'm stumped.  Has anybody seen this type of problem before?

Thanks,
Pete
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.