l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 24: LUGOD election season has begun!
Page last updated:
2004 Aug 16 13:33

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] X, other
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] X, other



list,
I'm now back again, and I will repost what I posted on 2004-08-07. Also,
sometimes I wish for a hex editor. Since emacs is supposed to do lots of
stuff, will emacs do this? If so, that is one more reason for me to
learn emacs. Between emacs and nvi I hope to be able to take care of all
editing needs. Currently I use mostly nvi, but I don't like how it does
hard linefeeds for line wrapping. Anyway:
I decided to try something with my XF86Config-4. I 
changed the driver from vesa to neomagic. Now, the darkness switching
problem seems to have gone away. I don't think this is related to the
framebuffer because the darkness problem was happening before I started
fiddling with framebuffers. However, the scroll-too-far problem is still
present, and maybe it is worse. The manpage for neomagic has some
options, so maybe I could improve things by tweaking them. The defaults
seem pretty good though, such as with acceleration on by default.

About the modules, I tried recompiling my kernel with a modular floppy
driver. I did make, make install, then make modules_install. When I did
make modules_install, it said it put the floppy module off of
/lib/modules/ and when I looked, they were in
/lib/modules/2.6.7/kernel/drivers/block/ . So that seems okay, I guess.
However, I tried copying a file from floppy and while it was copying
doing an lsmod from a different virtual console. That showed no floppy
module. When I do "cat /proc/config.gz | gunzip | less" it says I do
have a modular kernel but the floppy driver is just y, not m. The file
did copy despite no floppy module, so it must be compiled into the
kernel, which is consistent with my /proc/config.gz saying y for the
floppy driver. I know I said m when I did the configuration. Also, when
I tried to use the script that comes with the kernel source that 
extracts the configuration from the kernel, by saying 
"./extract-ikconfig /vmlinuz", it says: 
"ERROR: Unable to extract kernel configuration information.
        This kernel image may not have the config info.".
However, /proc/config.gz says:
"CONFIG_IKCONFIG=y
CONFIG_IKCONFIG_PROC=y".
So I deleted the whole kernel source tree and re-extracted the tarball.
Then I recompiled and installed, again with modular floppy and a few
other things. But /proc/config.gz still said I didn't have a modular
kernel. So I thought maybe I do have the new kernel except just no
modules. But I know that is not true because I made a non-modular change
to the kernel and that didn't show up in /proc/config.gz either. I said
y for a SCSI controller I know I don't have. I then recompiled and
reinstalled that kernel, and make install did invoke lilo. Then I
rebooted and /proc/config.gz said "# CONFIG_SCSI_AIC7XXX is not set"
which I know is the line I said y, not m or n, for. So I guess somehow
the newly configured kernel is not being installed. I googled on the
error message from that script and all that turned up was copies of that
script. So I don't know what to do about that.

Two other weird problems I'm having are that if I try to "make
menuconfig" on my kernel sources, it says "Unable to find the Ncurses
libraries". However I can successfully run various programs that ldd
tells me use ncurses, like vi and tetris-bsd. So how do I fix that? The
other weird problem is with the clock, which is set to UTC. When I got
back from Minnesota, the clock was a day and some hours behind. I
figured this was because of the computer relying on a screwy old clock
battery for a week and a half and I reset the clock to UTC. I thought
before that the computer knew that my timezone is PDT and so would
compensate against the UTC that the system clock gives. However, now
that the system clock is agains set to UTC, date (without the u switch)
says UTC time, but PDT where it says the timezone. When I do "date -u"
it says seven hours ahead of what UTC really is and what my system clock
says. So how do I let the system know that the clock is set to UTC and
not local time? Thanks very much.
Nick
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.