l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2004 Jul 17 16:21

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] Help: my c and e keys don't work anymore.
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] Help: my c and e keys don't work anymore.

My "c" and "e" keys stopped working in xterms on X.   They work just
fine on the console, so it's not a hw issue.  The only things that
happened recently:

1. My system froze this morning.  Required a reboot and fsck.  No
   "really bad" error messages were printed, just the usual "zero dtime"

2. I apt-get upgraded.  Can't remember what got upgraded last, but I
   don't think it was X related.

That's about it.  I tried restarting X (I'm ashamed to say I even tried
rebooting).  X is receiving an event for these keys.  The output of xev
for "e" is shown below (including the output for "r" to compare it with
it with a working key):

   KeyRelease event, serial 25, synthetic NO, window 0xc00001,
       root 0x58, subw 0xc00002, time 368034, (45,50), root:(49,408),
       state 0x0, keycode 26 (keysym 0x0, NoSymbol), same_screen YES,
       XLookupString gives 0 bytes:  ""

   KeyPress event, serial 25, synthetic NO, window 0xc00001,
       root 0x58, subw 0xc00002, time 368342, (45,50), root:(49,408),
       state 0x0, keycode 27 (keysym 0x72, r), same_screen YES,
       XLookupString gives 1 bytes:  "r"

so SOMETHING is happening.  In addition, I killed X and started it again
as a different user.  The "e" and "c" keys still didn't work.  So
whatever happened is global.

This is an area of X I know very little about.  Can someone please help?
"c" I can live without (although I do miss ctl-c), but I need my "e" key
very badly!  :)


In theory, theory and practise are the same.  In practise, they aren't.
GPG Instructions: http://www.dirac.org/linux/gpg
GPG Fingerprint: B9F1 6CF3 47C4 7CD8 D33E 70A9 A3B9 1945 67EA 951D
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.