l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 10: LUGOD Installfests coming again soon
Page last updated:
2004 Feb 17 13:29

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] FSTAB Questions
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] FSTAB Questions



On Tue 17 Feb 04,  9:34 AM, Robert G. Scofield <rscofield@afes.com> said:
> When I first installed SuSE 9.0 it automatically put my Windows partition in 
> /etc/fstab.  That was nice because I want to be able to use Open Office in 
> Linux to work on Windows files.  More importantly, I need to be able to back 
> up my Windows files with my Linux CD burning software.  I recently had to 
> install a new hard drive.  And I just noticed that, after re-installing SuSE, 
> the Windows partition was not being mounted.

hi bob,

out of curiosity -- why did you reinstall?

and when you say "windows isn't being mounted", do you mean at boot?
what happens when you type "mount /mnt/windows"?


> I've been playing around with 
> fstab and with the following configuration I can work on Windows files:
> 
> /dev/hda5            /                    ext3       defaults              1 1
> /dev/hda6            /empty               ext3       defaults              1 2
> /dev/hda10           /home                ext3       defaults              1 2
> /dev/hda11           /opt                 ext3       defaults              1 2
> /dev/hda9            /tmp                 ext3       defaults              1 2
> /dev/hda8            /var                 ext3       defaults              1 2
> /dev/hda1            /mnt/windows         vfat       umask=0               0 0
> /dev/hda7            swap                 swap       pri=42                0 0
> devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
> proc                 /proc                proc       defaults              0 0
> usbdevfs             /proc/bus/usb        usbdevfs   noauto                0 0
> /dev/cdrecorder      /media/cdrecorder    auto       ro,noauto,user,exec   0 0
> /dev/cdrom           /media/cdrom         auto       ro,noauto,user,exec   0 0
> /dev/fd0             /media/floppy        auto       noauto,user,sync      0 0
> 
> Here are two questions:
> 
> 1)  Does this order look okay?  Is /dev/hda1 in the right place?

it depends.  did you plug the new hard drive in IDE 4 slot A or slot B?
if you put it in slot B, the drive spins at a faster rate and can
prematurely burn out the motor.  a lot of people who complained about
IBM deskstars crapping out early were guilty of using slot B.  since
then, IBM has placed slot AB converters, so for modern deskstars, it
doesn't matter.  if you own one of these things and it says "CHS"
somewhere on the drive itself, you have an older model.

> Man fstab 
> says that order is important.
 
i can't see why unless you do something like mounting /usr/local under
/usr, you'd want to mount /usr first.  in your case, you prolly just
want to mount / before anything else (as we all do).  so it looks good
to me.

> 2)  Instead of "umask=0" I originally tried "defaults", and then "rw,user."  
> But with these, Open Office couldn't write to the Windows files.  (I've 
> haven't tried backing up yet.)  Umask=0 is working fine.  But here's the 
> question.  I've come across an old Mandrake 9.0 fstab and here's the entry 
> for the Windows partition:
> 
> /dev/hda1   /mnt/windows   vfat   iocharset=iso8859-1,codepage=850,umask=0 0 0
> 
> Is there some advantage to having this sort of complicated entry?

bob, that field of fstab (field 4) is essentially options for mount.  so
you can figure out what the options mean by doing "man mount".

in the case of iocharset, it appears that iocharset is used to convert
between 8 bit  uhhh.... "ascii" (with all due respect to the fact that
ascii is 7 bit) and unicode.

you should be OK you're only reading / writing in english.  note that
micah, mark and henry know this kind of thing WAY more than i do.

> Will I screw something up with my simple umask=0?

no, i don't believe so.

to be honest, i'm not sure what umask=0 does for you.  linux already
knows how to access vfat.  it already knows that there are no
permissions on vfat.  i never used this option on any dual boot i've
ever owned.

maybe someone can explain why it's necessary to set a umask for a vfat
filesystem?

> Should I copy the Mandrake entry into my SuSE system?

no.  you should do what works.  i know that sounds like a cop-out
answer, but it's the absolute truth.  

copying something is never a good thing to do.  let something serve as a
guide?  yes.  but blind copying?  never[1].

pete

[1] Unless you intend to back something up.  But even then, thought
should go into what to backup, when to backup and how to backup.

-- 
Make everything as simple as possible, but no simpler.  -- Albert Einstein
GPG Instructions: http://www.dirac.org/linux/gpg
GPG Fingerprint: B9F1 6CF3 47C4 7CD8 D33E 70A9 A3B9 1945 67EA 951D
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.