l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 10: LUGOD Installfests coming again soon
Page last updated:
2003 Dec 10 11:29

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] CVS and Apache: Not playing nice with each other
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] CVS and Apache: Not playing nice with each other



setting up the pserver can be tricky.  in fact, remote cvs
authentication can be tricky.  one of the bad things about cvs, which
will hopefully be improved by subversion.

here's what i use for inetd:

cvspserver stream tcp nowait.20 root /usr/sbin/tcpd /usr/sbin/cvs-pserver

two things:

1) nowait.20
2) i wrap cvs-pserver with tcpd (and you should too).

you might want to consider the ssh authentication method.   it's more
secure, and may or may not be more convenient (it's hard to say).  the
worst thing about it is that the person _must_ have a local account
(where with pserver they don't need a local system account.  just a
pserver account).  but you can cook things up so that they can't log in
to you system --- they can just run cvs commands remotely.

i recently moved from pserver to ssh authenticated cvs myself.

pete



On Wed 10 Dec 03,  9:50 AM, Richard Crawford <rscrawford@mossroot.com> said:
> I'm trying to get cvspserver running on my system (RH 8).  I added this
> line to my /etc/xinetd.conf file:
> 
> cvspserver stream tcp nowait root /usr/local/bin/cvs cvs
> --allow-root=/usr/local/cvs pserver
> 
> then issued:
> 
> # /etc/init.d/xinetd restart
> 
> ...which seemed to work okay.
> 
> Then I tried to check my e-mail, which I do with SquirrelMail... and when
> I did so, I got a ton of fputs() errors delivered up to my screen.
> 
> So I removed the line from xinetd.conf and restarted xinetd, then
> restarted httpd, and things worked fine again.
> 
> I tried inserting the line into xinetd.conf again, restarting xinetd and
> then immediately restarting httpd, but got the same errors.
> 
> I've checked _Open Source Development with CVS_ and a few websites that I
> Googled on cvspserver and xinetd, and I'm pretty sure I haven't messed up
> anything.
> 
> Anyone have any ideas?
> 
> Sláinte,
> Richard S. Crawford (AIM: Buffalo2K)
> 
> http://www.mossroot.com   http://www.stonegoose.com/catseyeview
> Howard Dean for America:  http://www.deanforamerica.com
> "I really didn't realize the librarians were, you know, such a dangerous
> group. They are subversive. You think they're just sitting there at the
> desk, all quiet and everything. They're like plotting the revolution, man.
> I wouldn't mess with them."
> --Michael Moore
> 
> 
> _______________________________________________
> vox-tech mailing list
> vox-tech@lists.lugod.org
> http://lists.lugod.org/mailman/listinfo/vox-tech

-- 
Make everything as simple as possible, but no simpler.  -- Albert Einstein
GPG Instructions: http://www.dirac.org/linux/gpg
GPG Fingerprint: B9F1 6CF3 47C4 7CD8 D33E 70A9 A3B9 1945 67EA 951D
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!