l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
December 2: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2003 Sep 30 10:22

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] Disk Failure - Data Retrieval?
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] Disk Failure - Data Retrieval?



As expected (and reported in my unresponded-to-post to this list on 09/15/2003), the hard disk I keep my media collection on has failed. Since this disk was the first one physically installed in my Mandrake box, it was /dev/hda1, all in one large partition. After an unclean shutdown, the system would not boot - I got an MBR: 0x?? error (nope, didn't write down the last two characters; so I don't know the specific cause) on power up. Tried a few more times: no luck, so it wasn't a transient error.

Suspecting that the disk was hosed, I then:

* swapped my IDE cables;
* booted from the Mandrake 9.1 CD in rescue mode;
* switched parameters in /etc/fstab to establish my mount points for various directories to /dev/hda and /dev/hdb instead of /dev/hdc and /dev/hdd, respectively;
* wrote the MBR to /dev/hda (that had previously been /dev/hdc);
* symlinked /etc/lilo.conf to /mnt/etc/lilo.conf;
* ran LILO; and
* rebooted.

So, now I'm back in business.

However, I still don't have my media collection online! Because I have the original CDs, I didn't keep backups of this particular disk. Unfortunate, but reasonable considering the expense of tape backup solutions and my current unemployment :^(

Short of re-ripping my insanely large CD collection, is there an easy way to retreive the data from my disk? Based on what I've tried so far, it appears that the boot sector and/or partition table of the disk are corrupted.

What I've tried so far:

# fsck.ext3 /dev/hdc1
e2fsck 1.32 (09-Nov-2002)
fsck.ext3: No such file or directory while trying to open /dev/hdc1

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

# fsck.ext3 /dev/hdc
e2fsck 1.32 (09-Nov-2002)
fsck.ext3: Attempt to read block from filesystem resulted in short read while trying to open /dev/hdc
Could this be a zero-length partition?

# fdisk -l /dev/hdc

(Nothing except a blank line results. Just to check, I verified another disk:)

# fdisk -l /dev/hda

Disk /dev/hda: 40.0 GB, 40027029504 bytes
16 heads, 63 sectors/track, 77557 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 507 255496+ 83 Linux
/dev/hda2 508 77558 38833368 5 Extended
/dev/hda5 508 1319 409216+ 82 Linux swap
/dev/hda6 1320 20102 9466600+ 83 Linux
/dev/hda7 20103 50911 15527704+ 83 Linux
/dev/hda8 50912 77558 13429720+ 83 Linux

(so it's not that I can't use fdisk...)

# sfdisk -l /dev/hdc

Disk /dev/hdc: 158816 cylinders, 16 heads, 63 sectors/track
read: Input/output error

sfdisk: read error on /dev/hdc - cannot read sector 0
/dev/hdc: unrecognized partition
No partitions found

Does anyone have any ideas?



--
Marc Elliot Hall www.hallmarc.net/quick_resume.html
P.O. Box 435
Shingle Springs, CA 95682
www.hallmarc.net Hire me!


_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.