l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2003 Aug 27 10:57

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] multisession cd-writing
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] multisession cd-writing

Ken Bloom wrote:
On 2003.08.26 08:27, Jonathan Stickel wrote:

I am trying to do multisession cd-writing.  My system is a laptop with a
Toshiba DVD/CDRW combo drive, running RH9.  I previously was able to use
gtoaster for trouble-free multi-session cd writes, but suddenly I
cannot!  The first write session is fine, but various errors occur on
subsequent sessions.

I don't know when the break occurred:  after I upgraded from RH8 to RH9,
or after I tried using a USB2 DVD+RW (which worked for reading, but not
quite for writing in Linux).

Anyway, I tried command line mkisofs and cdrecord to see if it would
work instead of gtoaster.  On a blank CDRW:

#mkisofs -r -J -f /home/jjstickel/temp/to_burn_symb/ | cdrecord -v
-eject -multi speed=4 -

writes and mounts an initial session OK.  To write some more, I try:

#cdrecord -v -msinfo
#mkisofs -r -J -f -C xx,yy -M /dev/scd0
/home/jjstickel/temp/to_burn_symb/ | cdrecord -v -eject -multi speed=4 -

seems to write OK; at least the output progress looks good and there are
no errors.  However, upon remount I can only see what written in the
first session (yes, I put something different in the target directory)!
 Any help out there?


One thing I found with my LG-8080-B CD-Writer was that I had to literally eject the cdrom in order to make it recognize that the data had changed. (mount -o remount doesn't work, and umount && mount doesn't work, only eject && mount). That could explain why my Windows CD burner software always used to physically eject the CD then suck it back in, even without me asking.
I thought I had this covered by using the eject option with cdrecord, but I must have been shoving it back in too quickly, or KDE's automount was being wacky. Anyway, I swear it wasn't working when I made the post, but this morning I put the cd back in and I can see everything after all! Well anyway, I know how to do command line cd-writing now.


vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.