l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
August 5: Social gathering
Next Installfest:
TBD
Latest News:
Jul. 4: July, August and September: Security, Photography and Programming for Kids
Page last updated:
2003 May 26 16:53

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Wireless card seems to "freeze" my wireless network
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Wireless card seems to "freeze" my wireless network



Version of pcmcia-cs?

I knew someone who was running RedHat who tried to get this card to work.
For them, it was a matter of getting the latest version of pcmcia-cs and
building by hand. He did not need or use WEP however.

Look at the docs for your pcmcia-cs and see the file "SUPPORTED.CARDS" and
look for "MA401" to see if it is listed as supported and how well.

In the SUPPORTED.CARDS file for pcmcia-cs-3.2.4 I see this in the section
for you card:

[orinoco_cs driver] [x86,axp,ppc,smp]
[ this driver supports multiple chipsets and some features may
not be supported for all cards ]
*CHOP*
        Netgear MA401RA
*CHOP*

Technically WEP is considered a feature. This could (but may not) be the
reason you see problems.

Other things to examine:
If you have access to configure advanced settings on your Wireless access
point, see if you can change the maximum packets sizes advertised. You may
want to drop them down by 40 bytes to see if this solves the problem.

Try upgrading the firmware on your wireless access point. When I bought a
LinkSysWireless Access point, I had to upgrade the firmware to get it to
work with Linux. Then, later firmware revisions permitted WEP to work with
it to Linux.

Try the card on a different OS to see if it is a hardware issue that
follows the card.

-ME



You could try getting the latest copy of pcmcia-cs to see if more
functionality exists for your card.


> The computer:
> 	Sony Vaio laptop running Debian 3.0r1
>
> The WAP: Linksys WAP11.
>
> The wireless card:
> 	Netgear MA401 inserted into PCMCIA slot
>
> When I boot up the computer, everything seems to work fine. The wireless
> card is detected and the appropriate drivers loaded.  By default, my
> computer activates eth0, my NIC card, instead of eth0, the Netgear
> wireless card.  I run the following commands to activate my wireless
> card:
>
> # ifconfig eth0 down
> # ifconfig eth1 up
> # iwconfig eth1 essid "HOGWARTS"
> # iwconfig eth1 mode Managed
> # iwconfig eth1 key xxxxxxxxxxxxxxxxxxxxxxxxxxxx restricted
> # dhclient eth1
>
> And this gets my wireless card running, and I can browse the web, check
> my e-mail, etc., just fine.
>
> After about five minutes, however, the wireless network seems to
> "freeze" or something.  At that point I can no longer get any wireless
> connectivity at all, and neither can any other computer with a wireless
> card on my network. If I shut down Debian on my laptop and boot into
> Windows, my wireless card won't work at this point.  Power-cycling the
> WAP seems to fix the problem, but that seems rather inelegant.
>
> How could my wireless card be freezing the network like this?  What
> should I be looking for?
>
>
> --
> --
> Slainte,
> Richard S. Crawford
> AIM: Buffalo2K / Y!: rscrawford / ICQ: 11640404
> http://www.mossroot.com http://www.stonegoose.com
> "It is only with our heart that we can see clearly.  What is essential
> is invisible to the eye."  --Antoine de Saint Exupery
> _______________________________________________
> vox-tech mailing list
> vox-tech@lists.lugod.org
> http://lists.lugod.org/mailman/listinfo/vox-tech
>
>

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.