l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
January 6: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2003 Apr 14 15:45

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] Kernel Panic: Lilo did not find Kernel
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] Kernel Panic: Lilo did not find Kernel



Hi, my name is Viet and I just subscribed to the LUGOD mailing list. I was wondering if there was any help available for what I'm going through.
(By the way, I am very much a newb, and have never compiled a kernel before) Here's my situation:

My box is running a dual boot sytem: One parition is running Win98SE
whilst the other is running Red Hat 8.0 with a 4-18 kernel. I recently downloaded the 4-20 kernel and compiled by using these commands:

make mrproper
make menuconfig
make dep
make install

Afterwards, I tried to go into my lilo.conf to make a third entry to point to the old kernel in case the new kernel didn't work.

Then I ran:

/sbin/lilo then it put out

Added Linux
Added Oldlinux (old linux kerkel :-p)
Added DOS

Everything seemed fine so far...

In accordance with Murphy's Law, Lilo was unable to find either of my kernels;
this leaves me in a very bad situation. I get the infamous "Kernel Panic" output. Right now, I'm running in Windows mode.

My guess is that I made a mistake in configuring my lilo.conf (did I mention that I was a newb?) and that it resulted in Lilo not finding either kernel.
As of right now, I have installed Cygwin and I downloaded a Redhat Recovery disk rpm (lilo-21.4.4-20.i386.rpm) from the internet. So far, I'm trying to
successfully un-rpm this file and then copy it to a floppy so I can finally
get back into Linux and restore my system. However, I'm having trouble running
rpm2cpio and cpio to do this. This is where I am at right now. What is the command
syntax for rpm2cpio, and for cpio? What do I do from there? Am I on the right track?

Thanks in advance for any help you can provide!





_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.