l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
April 21: Google Glass
Next Installfest:
TBD
Latest News:
Mar. 18: Google Glass at LUGOD's April meeting
Page last updated:
2003 Mar 31 17:52

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] Howto: run Mozilla 1.3 on Debian woody
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] Howto: run Mozilla 1.3 on Debian woody



  I recently got irritated at the 1.0.0 Mozilla in stable (woody)... 


  If you want to upgrade to Mozilla 1.3 use the following in 
/etc/apt/sources.list:
===
# Mozilla 1.3 backport from sid for woody
deb http://debian.relativ.org/ ./
===

Then as root run:
===
apt-get update
apt-get dist-upgrade
===

  Since I run a mixed stable/testing/unstable system I also need one of 
the following pin added to /etc/apt/preferences

===
Package: *
Pin: origin debian.relativ.org
===


  Warning the 1.3 source changes browser binary name from 'mozilla'
to 'mozilla-1.3', so you may want to create a link like:
===
ln -s /usr/bin/mozilla-1.3 /usr/local/bin/mozilla
===

  The 1.2.1 site below does not have this problem.
I didn't test the 1.1 site.


    Later,
      Mike Simons


  If you want a slightly older Mozilla 1.1 add the following lines to
/etc/apt/sources.list
===
# Mozilla 1.1, Galeon backport
deb http://people.fsn.hu/~pasztor/debian woody mozilla
===

  The 1.1 site includes Galeon which the others do not.

  1.2.1 is also available:
===
# Mozilla 1.2.1 for woody
deb http://people.debian.org/~frankie/debian/woody/kalem/ /
===


  If you need the pin, change "debian.relativ.org" to the site source you 
use above.


  If you have problems with apt crashing with a message similar to:
===
Reading Package Lists... Error!
E: Dynamic MMap ran out of room
E: Error occured while processing python-pyme (NewVersion1)
E: Problem with MergeList
/var/lib/apt/lists/http.us.debian.org_debian_dists_unstable_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
===

Then add the following line to /etc/apt/apt.conf   
===
APT::Cache-Limit 10000000;
===
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!