l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2003 Mar 19 22:15

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] SysRq
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] SysRq

I've used the low-latency patches before and it also has a switch to toggle
 it on and off in /proc/sys/kernel.  To enable sysrq:
echo 1 > /proc/sys/kernel/sysrq
The low-latency patch allows you to select whether or not to have this
 switch. Maybe the sysrq has that too in how you compile your kernel.

In X the magic-sysex keys won't show up.   The help, etc will only show up
only in a console.  The keys still work in X you just have to pray a bit.
However, I've been rather successful getting to a console from X via the
unRaw sysex key.  This seems to free the keyboard from X.  Then you can use a
Ctrl-Alt-Fn to get to a console and kill whatever is using all your CPU's or

On Tuesday 18 March 2003 11:29 am, Jonathan Stickel wrote:
> When I try alt-sysrq-h (to display magic-sysrq help) in KDE, my cpu runs
> for awhile but nothing seems to happen.  I wanted to avoid testing
> something more drastic, but since you asked, I entered init level 3 and
> tried a few (alt-sysrq-'h', 's', 'u', and 'b').  Nothing happens at all.
> Jonathan
> Peter Jay Salzman wrote:
> > redirected to vox-tech
> >
> > begin Jonathan Stickel <jjstickel@netscape.net>
> >
> >>I was previously unaware of the magic sysreq keys.  They do look useful,
> >> and I read the documentation as you suggest.  From what I can tell, it
> >>is compiled in my kernel (CONFIG_MAGIC_SYSRQ=y), but I am wondering if
> >>it is disabled with the run-time command:  "echo "0" >
> >>/proc/sys/kernel/sysrq", as suggested by the documentation.  In fact, my
> >>/proc/sys/kernel/sysrq contains the single character "0".  Where would I
> >>find this run time command?  Can I just delete it or comment it out?
> >>Thanks,
> >>
> >>Jonathan
> >
> > have you tried to use sysreq and it didn't work?
> >
> > pete
> >
> >>Peter Jay Salzman wrote:
> >>>hi doug,
> >>>
> >>>check out /usr/src/linux-2.4.20/Documentation/sysrq.txt
> >>>
> >>>it's very short.  basically, you make the kernel:
> >>>
> >>>1. flush buffers ("sync disks")
> >>>2. remount all partitions as read-only
> >>>3. reboot
> >>>
> >>>print screen == sysrq
> >>>
> >>>alt-sysrq-s    flush
> >>>alt-sysrq-u    remount partitions as read-only
> >>>alt-sysrq-b    reboot
> >>>
> >>>you can actually send TERM and KILL to all processes.   this is the kind
> >>>of thing you should really read about before using.   it's short and
> >>>well written.
> >>>
> >>>pete
> >>>
> >>>
> >>>begin R. Douglas Barbieri <doug@dooglio.net>
> >>>
> >>>>Okay, so explain to me the magic sysreq keys... :-) I experience
> >>>> lockups sometimes when I'm trying to start up Win4Lin. It hoses my
> >>>> machine so badly that Ctrl-Alt-Backspace won't even kill X (and
> >>>> Ctrl-Alt-Fn doesn't even work. I have to hard restart when that
> >>>> happens).
> >>>>

vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.