l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2003 Mar 24 15:27

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Re: Logitech MouseMan and XF86Config-4
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Re: Logitech MouseMan and XF86Config-4

> Date: Wed, 12 Mar 2003 10:43:03 -0800 (PST)
> From: Robin Snyder <resnyder@ucdavis.edu>
> To: vox-tech@lists.lugod.org
> Subject: [vox-tech] Re: Logitech MouseMan and XF86Config-4
> Reply-To: vox-tech@lists.lugod.org
> >
> > On Tue, Mar 11, 2003 at 03:59:13PM -0800, Robin Snyder wrote:
> > > I occasionally want to switch to a second mouse, which is a Logitech
> > > Mouseman mouse with two buttons and a scroll wheel/button (not cordless)
> > > and have been trying to write a second version of my XF86Config-4 file to
> > > accommodate the new mouse.  If I use protocol "microsoft," the cursor
> > > tracks the mouse motions appropriately, but I have to use third button
> > > emulation to paste text.  Everything that I've seen on the net suggests
> > > that the correct mouse protocol is IMPS/2 and that I should use device
> > > "mouse," but these give the classic wrong protocol random mouse movements.
> > > Anyone know what I should do to get the third button working?  I've tried
> > > adding the line
> It's a ps/2 mouse.  I tried the PS/2 protocol as well as the IMPS/2
> protocol but both cause the cursor to shoot around wildly and hang out
> near the screen edges in classic "I'm unhappy with my protocol"
> fashion.

I use a Logitech Trackman Wheel (so stop reading if this doesn't apply 
to you).

Here is my /etc/gpm.conf file sans comments (this file is Debian only)

Here is an excerpt from my /etc/X11/XF86Config-4
(many comments removed)

Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "MouseManPlusPS/2"
    Option "Device"      "/dev/psaux"
#   Option "Device"      "/dev/gpmdata"
    Option "ZAxisMapping" "4 5"
    # ChordMiddle is an option for some 3-button Logitech mice
    Option "ChordMiddle"

Note the commented /dev/gpmdata. I had tried using gpm as a raw 
repeater, and letting X pick up its data from /dev/gpmdata, but that 
caused the problem you speak of with the mouse bouncing around. I 
couldn't get the problem to stop until I disabled gpm's repeater mode 

Previously, when I used a Logitech Optical Mouse (that didn't say 
anything about MouseMan anywhere), my protocol in X was IMPS/2, and my 
protocol in gpm was exps2

I usually have a GPG digital signature included as an attachment.
If you don't know what it is, either ignore it or visit www.gnupg.org
Fingerprint: D5E2 8839 6ED3 3305 805C  941F 9476 A9BD E2B2 CAD1
The key is keyID E2B2CAD1 on pgp.mit.edu

Attachment: pgp00005.pgp
Description: PGP signature

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!