l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2003 Mar 01 08:31

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] trouble generating images with PHP 4.2.2
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] trouble generating images with PHP 4.2.2

Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
--- Begin Message ---
Hi everyone-

I'm trying to generate images for the first time with PHP and
my script's source code starts like this:
  $height = 200;
  $width = 200;
  $im = ImageCreate($width, $height);
and then it goes on to draw the image and so forth, but that doesn't
matter at this point, because apparently my PHP build isn't supporting
any image-creating functions at all.  I get the following error:

Fatal error: Call to undefined function: imagecreate() in
/usr/local/apache/html/simplegraph.php on line 4

which is the error that everyone gets when they don't have GD installed-
BUT, as of PHP 4 *it comes bundled with php itself*-- so what gives??

I searched for hours for support groups with messages from people
experiencing similar problems, but they all were either using either php 3
or <, windows machines (GD not enabled by default for windows users),
or had my exact complaint without any replies or resolutions.

I think the problem may lie somewhere within my PHP's configuration
options, and how they may not be taking effect.  According to my phpinfo,
I used the following command to configure my php:

'./configure' '--prefix=/usr/local/php' '--with-mysql=/usr' '--with-xml'
'--with-apache=../apache_1.3.26' '--with-curl=/usr/local/curl'
'--with-pspell=/usr/local/pspell' '--enable-shared-pdflib'

and I read somewhere that to use the built-in GD that comes with PHP as of
v. 4 I need to use the '--with-gd' option.  So I reran the ./configure
command exactly the same way, but this time tagging on the '--with-gd'
at the end, then make then make install, then I stopped and restarted
apache but then I still get the same error message and my phpinfo file
does NOT reflect the change that I made to my configuration options.
Could it be then that there is just something I'm doing wrong here and I'm
not fully flushing things?

I'm using RH linux 7.1...

any help is greatly appreciated.

--- End Message ---

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.