l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
September 2: Social gathering
Next Installfest:
TBD
Latest News:
Aug. 18: Discounts to "Velocity" in NY; come to tonight's "Photography" talk
Page last updated:
2003 Feb 10 19:13

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] X server help
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] X server help



hi jennifer,

sorry your X stopped working.  that blows.  before saying anything, let
me just give some advice for the future.

unless your video card is supremely new, you'll never need to update the
kernel to get X working.  and then, only if your card provides hardware
accelerated graphics functions (or for a frame buffer).

in other words, a kernel update should have no effect on normal mode 2D
unaccelerated X.  there are many good reasons to keep an updated kernel,
but that's not one of them.

also, if you had X working but for some reason it broke, re-installing X
from source is also not the way to go (although it IS impressive (;).
it's usually just a configuration file that got over written.



that said, this error:

> PreInit failed for input device "Mouse1"
> No core pointer

says to me that you have a serverlayout section that makes mention of
Mouse1, but Mouse1 was never defined.   here's a sample from my
XF86Config:


   Section "Screen"
      Identifier "Default Screen"
      ... blah blah blah ...
   EndSection
   
   
   Section "InputDevice"
      Identifier "Generic Keyboard"
      ... blah blah blah ...
   EndSection
   
   
   Section "InputDevice"
      Identifier  "Generic Mouse"
      Driver      "mouse"
      Option      "CorePointer"
      Option      "Protocol"        "ImPS/2"
      Option      "Resolution"      "2000"
      Option      "Device"          "/dev/psaux"
      Option      "Emulate3Buttons" "false"
      Option      "buttons"         "5"
      Option      "ZAxisMapping"    "4 5"
   EndSection
   
   
   Section "ServerLayout"
      Identifier  "Default Layout"
      Screen      "Default Screen"
      InputDevice "Generic Keyboard"
      InputDevice "Generic Mouse"
   EndSection



the ServerLayout section describes all the inputs/outputs that X will
use: mice, monitors, brain wave collectors, IV needles, etc.

each item in ServerLayout (ie- "Generic Keyboard") must have a
corresponding section describing that item.  you can see this from my
snippet above -- input sections called "Default Screen", "Generic
Keyboard", and "Generic Mouse".

X will refuse to run if ServerLayout makes reference to an input or
output device not defined by a section.


it _looks_ like your XF86Config has a ServerLayout section that that
contains the line:


   Section "ServerLayout"
      ...
      InputDevice "Mouse1"
   EndSection


but has no section that looks like:


   Section "InputDevice"
      Identifier  "Mouse1"
      ...
   EndSection


now, what to do about it?  if i diagnosed this correctly, the best thing
you can do is read man XF86Config-4 and write your own input device
section, using mine as a template.

the simplest (and best) answer is to see if you have a file called
something like:

/etc/X11/XF86Config.bak
/etc/X11/XF86Config.0
/etc/X11/XF86Config.rpmsave

or something like that, since this would be the file that got displaced
when redhat updated your system.


it's kind of hard to tell without looking at your config file, but i
think this might be correct.

btw, i am embarrased to say i don't keep backups.  however, there are
certain files on my system that i do keep backups of, and XF86Config is
one of them (any config file that takes me more than 5 minutes to tweak
i have backed up).

hope i got this right...
pete


ps- you also may want to do a startx 2>X.err and look for any other
suspicious errors.



begin Jennifer Stickel <jrstickel@ucdavis.edu> 
> Hi all,
>     I am having technical difficulties with XFree86.  A while back, I
> tried to update my video drivers.  It worked for the setup that I had
> but not with any of the update that came out (I am using RH 8.0).  So
> recently I tried to get my video card to work with the newer kernel
> version available.  Now I have lost all ability to use X.  I tried
> uninstalling my drivers and it won't rebuild the newest source rpm.  I
> then tried downloading the newest version of XFree86 binaries.  They
> seem to install correctly and the configuration script runs, but doesn't
> make my mouse work properly.  Then when I type startx at the prompt, it
> tries to start X but then I get the error message
> 
> PreInit failed for input device "Mouse1"
> No core pointer
> 
> Fatal server error:
> Failed to initialize core devices
> 
> Can anyone help me to figure out how to get X back and running on
> machine?
> 
> Machine Specs:
> Dell Optiplex
> 512 MB RAM
> NVIDIA Riva TNT2 Model 64 video card
> 
> RedHat 8.0 / Windows 2000 Pro dual boot
> 
> Thanks!!
> 
> Jennifer Stickel
> 
> _______________________________________________
> vox-tech mailing list
> vox-tech@lists.lugod.org
> http://lists.lugod.org/mailman/listinfo/vox-tech

-- 
First they ignore you, then they laugh at you, then they fight you,
then you win. -- Gandhi, being prophetic about Linux.

Fingerprint: B9F1 6CF3 47C4 7CD8 D33E 70A9 A3B9 1945 67EA 951D
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.