l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2003 Jan 25 19:14

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] newbie now having trouble with pico
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] newbie now having trouble with pico

On Sat, 25 Jan 2003, Katie wrote:

> problem #2 of ??????? :-)
> So now I'm trying to install pico.  I downloaded it and tried
> installation through KPackage, but was told I needed:
> libtinfo.so.5
> I looked it up on rpmfind and it said it was contained in 
> ncurses-5.2-34.i686(ori386).rpm
> which I downloaded, but when I tried to install it I got:
> <ome/katie/.kpackage/ncurses-5.2-34.i686.rpm;echo RESULT=$?
> error: failed dependencies:
> 	libncurses5 = 5.2 is needed by libncurses5-devel-5.2-27mdk
> 	libncurses5 >= 5.2 is needed by php-readline-4.2.3-1mdk
> 	libncurses5 is needed by scli-0.2.9-2mdk
> 	libpanel.so.5   is needed by python-2.2.1-13mdk
> This doesn't make sense to me.  What do I do?

I am no rpm expert, but these errors suggest to me that rpm was trying to
remove ncurses and complaining about it.  Total guesswork: It may be
attempting to remove it due to the way you are invoking it... did you tell
it to update ncurses, or did you tell it to install ncurses? the latter
may try to remove equivalent packages before installing the one you

If the ncurses package really is already installed, then it may be a
faulty install.  You may have "libtinfo.so.5.1" or something, and need a
symlink from the generic library name to the specific one (something like
"ln -s /lib/libtinfo.so.5.1 /lib/libtinfo.so.5".

After googling around a bit though, I am more inclined to think you should
look for a different rpm for pico, because that library seems to be pretty
unusual.  I am running Debian, and have pico installed, and my version
does NOT need that library... whatever functionality it provides is part
of libncurses.so.5.

Note that "pico" actually comes with "pine" (normally), so you can
probably find an rpm for "pine" and get what you are after.

Also, as was pointed out elsewhere, nano is a clone of pico, that may do
the trick.

Jeff Newmiller                        The     .....       .....  Go Live...
DCN:<jdnewmil@dcn.davis.ca.us>        Basics: ##.#.       ##.#.  Live Go...
                                      Live:   OO#.. Dead: OO#..  Playing
Research Engineer (Solar/Batteries            O.O#.       #.O#.  with
/Software/Embedded Controllers)               .OO#.       .OO#.  rocks...2k

vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.