l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
January 6: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2002 Sep 06 11:13

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] Robin Snyder's problems configuring X4 on workstation
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] Robin Snyder's problems configuring X4 on workstation



Sorry Pete.  I'm getting help from multiple sources, which makes the story
hard to follow.  Here's the story as it stands right now.

I've tried two different methods to configure X4.  Each results in a
different set of problems.

1.  XFree86 -configure.  This results in screen flicker and fonts that are
too small, not just in terminal windows but throughout the desktop.
Netscape also sometimes displays webpages as a mess of colored lines.  (I
may be able to see the site normally at first.  The mess sometimes occurs
when I try to enlarge the window, to better read the microscopic fonts.)

First, fonts.  I think X can't find some fonts, which means that I'm
forced to use microscopic fonts.  I believe this because startx gives me
the error message

Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/,
removing from list!

(I think it complains about another font as well--I forget which.)  I have
checked and Speedo is where it is supposed to be.

Second, flicker.  XFree86 -configure correctly records my horizontal and
vertical scan ranges, which are 30-97 and 50-160, respectively.  However,
the configuration file it produces doesn't have the usual 1600x1200 @ 77Hz
type entries that I'm accustomed to, so I can't fiddle with those.
Indeed, it only seems to produce a single mode.  I've tried cycling
through modes with ctrl-alt-minus, but I only get the one mode.  I will
append the config file from XFree86 -configure at the end of this.

2. dpkg-reconfigure xserver-xfree86.  This is the other way I've tried to
configure X4.  This method has no flicker, now that I've gone through the
advanced setup, and the desktop font size seems reasonable, but
gnome-terminal crashes with a floating point exception.  For some reason,
netscape also opens in a window that is bigger than my screensize--so
large I can't get to the corner that would allow my to resize the window.
I'm not sure what's up with that.

I'm not getting flicker because this configuration method lets me specify
horizontal and vertical refresh rates explicitly and lets me choose valid
modes.  I've checked on the web to see what modes I'm capable of
(1600x1200@77, 1280x1024@90, 1024x768@118, 800x600@148), so I know those
are correct.

I have no idea why gnome-terminal would crash with one configuration file
and not the other.

I have no idea what's up with netscape, although my instinct tells me that
this problem may have more to do with netscape than with my configuration.

			- robin.

---------------- XF86Config-4 produced by XFree86 -configure -------------

Section "ServerLayout"
	Identifier     "XFree86 Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	ModulePath   "/usr/X11R6/lib/modules"
	FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
	FontPath     "/usr/X11R6/lib/X11/fonts/Speedo/"
	FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
	FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
	FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
	FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
	Load  "dbe"
	Load  "dri"
	Load  "extmod"
	Load  "glx"
	Load  "pex5"
	Load  "record"
	Load  "xie"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "keyboard"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
#	Option      "Protocol" "auto"
	Option      "Protocol" "microsoft"
	Option      "Device" "/dev/mouse"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "VSC"
	ModelName    "PF790"
	HorizSync    30.0 - 97.0
	VertRefresh  50.0 - 160.0
EndSection

Section "Device"
	### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "PciRetry"           	# [<bool>]
        #Option     "SyncOnGreen"        	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShowCache"          	# [<bool>]
        #Option     "Overlay"            	# [<str>]
        #Option     "MGASDRAM"           	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "UseFBDev"           	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "SetMclk"            	# <freq>
        #Option     "OverclockMem"       	# [<bool>]
        #Option     "VideoKey"           	# <i>
        #Option     "Rotate"             	# [<str>]
        #Option     "TexturedVideo"      	# [<bool>]
        #Option     "Crtc2Half"          	# [<bool>]
        #Option     "Crtc2Ram"           	# <i>
        #Option     "Int10"              	# [<bool>]
        #Option     "AGPMode"            	# <i>
        #Option     "DigitalScreen"      	# [<bool>]
        #Option     "TV"                 	# [<bool>]
        #Option     "TVStandard"         	# [<str>]
        #Option     "CableType"          	# [<str>]
        #Option     "NoHal"              	# [<bool>]
        #Option     "SwappedHead"        	# [<bool>]
        #Option     "DRI"                	# [<bool>]
	Identifier  "Card0"
	Driver      "mga"
	VendorName  "Matrox"
	BoardName   "MGA G400 AGP"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Depth     1
	EndSubSection
	SubSection "Display"
		Depth     4
	EndSubSection
	SubSection "Display"
		Depth     8
	EndSubSection
	SubSection "Display"
		Depth     15
	EndSubSection
	SubSection "Display"
		Depth     16
	EndSubSection
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection



_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.