l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2002 Aug 31 13:20

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] Large Hard Disks
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] Large Hard Disks

Somehow I thought I was over all this "large hard disk" headache, but the
CHS legacy lives on for those of us who try to put together yesterday's
motherboard with today's hard disks, and cabling is getting more
complicated too.  I figured I would describe my experience for others to
learn from, and I hope learn from any followup comments.  Just to be
crystal clear, I am primarily interested in minimizing cost rather than
maximizing performance.  :)

My configuration: I have an ASUS P5A-B motherboard with AMD K6-2 450MHz
CPU, with (I believe) a UDMA-33 (pio3 and pio4) IDE interface.  I started
out with a Maxtor 90871U2 10G hard disk, 40pin IDE cable, and BIOS dated
1998.  Running Debian sarge, with kernel 2.2.20, with no dual boot

I bought a Seagate ST380020A 81GB hard disk for $79 ($85 total) from
www.basoncomputer.com, and hooked it up as primary slave.  The BIOS hit
the IDE drive inventory and hung checking that drive.

I tried putting it alone as master, no dice.  I installed a UDMA-66 cable
(80 pins), no dice.  After talking to Peter S, I downloaded a BIOS upgrade
(gotta pull out the bootable MSDOS disk), and upgraded... April 2001
version.  No dice.

I went back to Google, and discovered that there were two BIOSes with
exactly the same date and version number for this motherboard... one with
"no sound support and >32G" and the other with "sound support and <32G".
Grabbed the no sound version and wrote it in. Then the bios passed the
drive check, but hung when reporting the drive size.

I installed the "pretend I am 32GB" jumper, and it worked.  Yuck... I paid
for 50GB I can't use? Gotta do better...

Proceeding on clues from the Large-Disk-Howto, I removed the stupidity
jumper and entered the bios setup program and told the BIOS that the disk
was not in LBA mode, but in "normal" mode, with a default 8GB geometry.  
The bios check now runs ok, the size is wrong but doesn't hang, but Linux
now sees the entire disk.  Apparently fixes introduced around 2.2.5 allow
Linux to decipher the true state of affairs and ignore the bad information
in the BIOS.  I would never have guessed that I would be better off with a
CHS configuration rather than a LBA configuration in bios.

hdparm -t says the disk is running at 14.8MB/s. The only funky bit I 
have noticed so far is that hdparm -b fails with
"HDIO_GET_BUSSTATE failed: Input/output error".

Well, now I have enough disk space to install UML. :)

Jeff Newmiller                        The     .....       .....  Go Live...
DCN:<jdnewmil@dcn.davis.ca.us>        Basics: ##.#.       ##.#.  Live Go...
                                      Live:   OO#.. Dead: OO#..  Playing
Research Engineer (Solar/Batteries            O.O#.       #.O#.  with
/Software/Embedded Controllers)               .OO#.       .OO#.  rocks...2k

vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.