l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2002 Jun 20 06:58

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] In Denial About These Hard Drive Problems
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] In Denial About These Hard Drive Problems

begin Richard S. Crawford <rscrawford@mossroot.com> 
> This afternoon I noticed that my /home partition was expanding 
> again.  Normally when I run df -h it shows /home as being filled to 52% of 
> the available space; this afternoon, though, it was up to 100%.  I was away 
> from my computer and logging in remotely so I didn't want to do anything 
> too drastic.  I just found some wine processes that were running and killed 
> them, then deleted some extra tar files that I'd accumulated, to bring 
> things down to 98% so that my computer could keep running until I could get 
> home and reboot it, which is what stopped this problem before (I never did 
> figure out what was causing it).
richard, your computer won't suffer if /home is full as long as /home is
separate from / and /var.

your computer won't suffer even if / and /var are listed as 100% full.
linux keeps some extra room for rootly stuff so that your system can run
smoothly even if df reports 100% full

> So when I rebooted, I found some root filesystem errors, fixed them with 
> fsck /.  Then X wouldn't start.  I checked the message log and saw this 
> error:
>         fatal error: could not open default font fixed
> (or something like that).
that shouldn't have been a show stopper for X.  the problem lies

> Fearing nasty trouble, I decided I'd take the simpleton's way out and just 
> repair things from my installation disk.

not sure i know what that means.

> That process complained because 
> I'd created a symbolic link to /var on a large extra partition on my hard 
> drive (it wanted me to transform the absolute symbolic link /var to a 
> relative symbolic link -- something that is outside my realm of knowledge, 
> I'm afraid, though I did try to find it in my books).
> I decided I'd simply move the files in /var back to the root partition.  I 
> tried to start this process by creating a temporary directory in / with the 
> command,
>         # mkdir /var2
> ...to which I got this error:
>         could not create directory /var2.  Input output error.
> ...and that just seems terrifying to me.
> I'm running a Red Hat 7.2 system, not quite brave enough to do a full 
> reinstall of Linux (though I might just do that, after copying all of my 
> documents to a CD).

for heavens sake, don't reinstall.  that's what separates real linux
users from windows users.  windows users reinstall.  linux users fix.
resist the temptation.   reinstalling an operating system *should* be a
last resort.  unfortunately, microsoft made it a first line of attack.

> I hope I've provided enough information.  What else could I be doing?
unfortunately, i feel like there's not enough information, even though
you provided quite a bit of detail.

can you reboot and then email me (not post) your dmesg and X 2> X.err
and i'll take a look?

linux can often generate terrifying sounding errors for small reasons.
don't worry.

vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!