l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
October 7: Social gathering
Next Installfest:
TBD
Latest News:
Aug. 18: Discounts to "Velocity" in NY; come to tonight's "Photography" talk
Page last updated:
2002 Jun 03 11:00

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Problem using GUI apps for dialup/PPP in RH7.3
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Problem using GUI apps for dialup/PPP in RH7.3



On Fri, 31 May 2002, Ron Erhardt wrote:

>    All,
> 
>     I'm not brand-new to Linux (or Unix), but I am new
> to getting 'external devices' to work in a GUI environment
> under Linux. 

I have never used GUI tools for PPP... I have always just set up the
configuration files.  Not to say they aren't cool, but I cannot hold your
hand through the dialog boxes.

> HW:
>     Sony Vaio P4
>     external USR 56K V.90 modem
>     (system also has an internal winmodem)
> 
>     system is dual-boot with win-me
> 
> Problem Notes:
> - system is very stable, and I'm able to use most everything
>    other than my Epson C80 USB (which I believe I have a
>    fix for) and the modem (with GUI apps)
> - the 'system' knows the modem is there, and when it's not
>    turned on at boot time
> - I have (although it escapes me now how I did it) success-
>   fully talked to the modem (miniterm, I think)
> - I most often use the Gnome GUI, although I've also used
>    KDE (prefer Gnome)

No one has spoken up about GUI tools, but then again there are many, and
you have not indicated which ones you have tried, or what the result was
when you tried.  Usually it is possible to use these tools in either KDE
or Gnome.

>     I've checked for all the files/contents that I know about,
> but lack a good 'global' picture of all of the files/paths/cont-
> ents that *need* to be there for this to all work. 
> 
>     Any help will be appreciated.

I would recommend reading the PPP-HOWTO, on your hard disk (use "locate"
to find and "less" or "zless" to view) or at http://tldp.org.  Note that
you can probably bypass their instructions to recompile your kernel and
download sources, but you should pay attention to their diagnostics to
confirm that all the right files are present.  If they aren't, we may have
something more concrete to talk about.

In a nutshell, you need to configure the files in /etc/ppp and possibly
/etc/chatscripts depending on your distribution (which you never named). I
have certainly heard that GUI tools to help you do this exist, but I have
never used them myself.  Some of the ones I have seen are very
distribution-specific, others might not be.

In my experience, PPP setup has not been as brainless as it is in Windows
because MS makes a lot of assumptions about the configuration of the other
end of the connections that the Linux implementations usually don't.  If
some of the GUI programs out there are making these assumptions now, one
might expect their use to be similarly "easy" until something isn't as
expected, at which point the GUI leaves us who see your message unable to
tell where the problem is.

Some things to check:

a) serial to modem works? (apparently)
b) ppp module loaded ("lsmod" has ppp? "modprobe ppp" to insert...)
c) /etc/ppp/options okay? (right serial port)
d) chatscript  happy with your modem?
e) sometimes there is a symbolic link "/dev/modem" that points to the
appropriate serial port device ("/dev/ttyS0"?) that is missing or pointing
at the wrong device...
f) any messages in /var/log/messages or other /var/log/ file?

If none of these things appear to be wrong to you, telling us which things
you checked and how (verbatim output is often helpful)  may jog our
collective minds a bit.

---------------------------------------------------------------------------
Jeff Newmiller                        The     .....       .....  Go Live...
DCN:<jdnewmil@dcn.davis.ca.us>        Basics: ##.#.       ##.#.  Live Go...
                                      Live:   OO#.. Dead: OO#..  Playing
Research Engineer (Solar/Batteries            O.O#.       #.O#.  with
/Software/Embedded Controllers)               .OO#.       .OO#.  rocks...2k
---------------------------------------------------------------------------

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.