l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 10: LUGOD Installfests coming again soon
Page last updated:
2002 May 05 16:53

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] 4.21 Installfest Follow up--Red Hat 7 Sound/Modem configu
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] 4.21 Installfest Follow up--Red Hat 7 Sound/Modem configuration problems resurface



On Sun, May 05, 2002 at 12:29:27PM -0700, Gregory Weber wrote:
> I think Peter & then Michael (?) spent the better part of 2 hours tackling
> the problem. The solutions involved some extensive use of setserial and
> other commands that are beyond my newbie abilities.

Gregory,

  There was a lot of time wasted playing with setserial because originally
thought it was a PCI device which would have meant isapnp was useless...
It sure didn't seem like 2 hours, but it took a while.

  The solution was since it's a ISA PnP card (not PCI) all that needed
to happen was the devices had to be enabled...
  (pnpdump -c > /etc/isapnp.conf; isapnp /etc/isapnp.conf) don't run that 
unless you want to wipe out whatever is there now.
  Then the kernel needed to be told what IRQ and such the device used 
(with setserial), but I think I setup the modem for a regular standard
IRQ and ioport... so that setserial wasn't needed.


> During the installfest, there was a temporary account ("p") set up on my
> system.  Last night, trying to clean things up, I deleted the temporary
> account (after first backing up to a parallel port zip drive I'd
> successfully mounted on my own, using the command "tar -cvzf
> /mnt/zip/homebkp.tgz /home").
> 
> After deleting the /p account.

  I thought the p account was deleted before you left.  The home directory
might not have been, but the account should have been.


> I've now lost my modem again. (The sound card is still working.)

  That directory should have had _nothing_ to do with the functioning of
your modem.  I would need to take a look at what is wrong...


> I tried to restore from the backup file, but when I ran
> the command, "tar -xvpf /mnt/zip/homebkp.tgz" I get error messages that say
> it's not a tar file.  I don't know if the zip drive file is corrupted or
> not.

  You need a 'z' added to the options list. '-xzvpf'

> In any event, I'd simply like to recreate the magic that got around the
> sound/modem conflict.
> 
> Can anyone who was there help?

  Run the following (which are read-only commands and will not fix things),
and email the results to list.

=============
for l in /dev/ttyS*; do setserial -a $l; done

grep -vE '^#|^$' /etc/isapnp.conf

cat /proc/isapnp 

ls -l /etc/rc.boot
ls -l /etc/isapnp.conf
=============

    TTFN,
      Mike
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.