l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2002 Apr 12 16:27

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] Touble with Printer Set-up (long)
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] Touble with Printer Set-up (long)

Hi everyone,

I'm a new Linux user, and am having trouble getting my printer to work.  I'll start by listing the computer hardware, and then give a detailed list of what I've tried so far.  Any help would be greatly appreciated, and I apologize if this question has been answered before (if so, point me to the past thread).

Anyway, this message is a bit long, so here goes:

I installed Red Hat 7.1 on my Dell Dimension 4100 on one hard drive, and Windows 98 on a second hard drive.  Next, I set-up the PPP without too much trouble.  I went to www.linuxprinting.org, and they seemed to be recommending the Epson Stylus C60 as a good, well-supported option.  It was on sale, so I bought it.

So here's how I tried to set it up:

1.)  www.linuxprinting.org referred me to an Italian website:  space.it/computer/wvtberti, where they recommended using a CUPS install with gimp_print.

2.)  Downloaded four files:

3.)  They recommended deleting several files to avoid problems, so following their advice I did the following:

rpm -e printconf-gui
rpm -e printconf
rpm -e LPRng

while deleting the printconf it listed 5 files that couldn't be deleted, so I deleted them manually:

This whole step made me nervous.

4.)  Copied a file called gimp_print-cups.spec as a text file into /usr/src/redhat/SPECS

5.)  Executed the following commmands:
rpm -Uvh cups-1.1.14-0.i386.rpm
rpm -Uvh cups-devel-1.1.14-0.i386.rpm
rpm -Uvh cups-pstoraster-1.1.14-0.i386

showed 100% with no errors

6.)  cd /usr/src/redhat/SPECS
rpm -bb gimp_print-cups.spec

returned the error:
error:File /usr/src/redhat?SOURCES/gimp_print-4.2.0.tar.gz: No such file or directory

tried moving gimp_print-4.2.0-1.src.rpm to /usr/src/redhat/SOURCES
but it still had problems, so moved it back

then did:
rpm -Uvh --force gimp-print-4.2.0-1.src.rpm

100% ok

then did:

cd /usr/src/redhat/SPECS
rpm -bb gimp_print-cups.spec

pages of things scrolled by, and looked ok with no obvious error messages

7.)  Rebooted, logged in as root, went to http://localhost:631/admin
logged in as root
Went through their menu, and it looked like only two reasonable driver choices:
EPSON New Stylus Color Series CUPS v1.1
EPSON Stylus Color Series CUPS v1.1

tried both

also, printer was hooked-up to parellel port, so selected this option.

It showed my printer being all ok, but would not print a test page

Note, had lots of network errors while doing this in Netscape

8.)  went to .bash_profile as root and added the following:

PRINTER="name I gave the printer"
added PRINTER to export

source .bash_profile

then did:
export | grep PRINTER
and it returned:  declare -x PRINTER="name I gave the printer"

9.)  At this point they claim you can just use printtool or printconf, or use the CUPS web-based interface to finish things up.  
Neither printtool nor printconf are recognized commands now on my machine, so that won't work.  I suspect it's because of step 3.) above.  By the CUPS web-based interface I assume they mean the site in step 7.) above, which shows everything to be set-up, but won't print a test page.

Whew, that was a lot of typing, but I figured I should include everything.  Any suggestions for fixing this thing, and getting my printer to work?

Thanks very much for reading, and for any suggestions.  Remember, I'm a real newbie, so you may have to spoon feed me.


vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!