l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2002 Feb 16 14:30

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] usb woes
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] usb woes

begin Jeff Newmiller <jdnewmil@dcn.davis.ca.us> 
> On Fri, 15 Feb 2002, Peter Jay Salzman wrote:
> >    of course, it's _possible_ that the cable is bad, but i seriously
> >    doubt it.  i'm trying to set the visor up on rhonda's windows machine
> >    right now, but i'm nearly certain it will work.
> Note that the driver said it had detected two ports in your hub. If you
> have ports in both the front and back of your computer, try using only the
> front ports or only the back ports.  That is, unplug all cables but the
> one you are working with if possible.
i *suspect* the problem may have been usb code interacting with smp
code.  tried it on lucifer and usb seems to be functional.   wild claim
and i don't have much evidence to back it up other than it "worked" on a
UP machine, and i read that USB needs special attention on SMP machines.

i still can't sync the visor though.  coldsync segfaulted.  recompiled
it with -g, did a backtrace, found a null pointer dereference and sent a
bug report to the developers.

i need to take a break from this.  i've been at it since noon.  i'll try
again using pilot-link and other software.  but at LEAST i can now make
FIRST CONTACT with the visor over usb.  now all i need to do is coax the
vulcans to come out of their ship.

btw, i found the problem with the /proc/bus/usb entries, or lack
thereof.   i needed to set


and then mount the device filesystem in fstab:

none       /proc/bus/usb usbdevfs default                    0 0

i did all this on lucifer, my UP machine.  i'll try recompiling the
kernel and mounting the devfs on satan and try again to see if i get
that wierd "bad cable" message.  it might clear things up.

btw, has anyone gotten 2.5.2, 2.5.3, 2.5.4 to compile?  i'm getting
really stupid compiler warnings like "int format, long int arg" that
finally bomb out.   kernel cousin warns that not many people have been
able to compile 2.5.4, but the the previous 2 don't seem to want to
compile for me either[1].

btw, the visor prism is selling for 220 at fry's.   it's pretty darn
awesome.  i can't wait to get this thing working under linux!


[1]: not the linking problem.  i learned how to fix that.  if anyone is
interested, edit arch/i386/vmlinux.lds and comment out the line that
says *(.text.ext) from the DISCARD section.  fixed the linker error for

Enron..safe legal abortion..civil liberty..repealing ICBM treaty..deficit..
What's worse?  Screwing an intern or screwing an entire country?

PGP Fingerprint: B9F1 6CF3 47C4 7CD8 D33E  70A9 A3B9 1945 67EA 951D
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.