l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 24: LUGOD election season has begun!
Page last updated:
2001 Dec 30 17:00

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
RE: [vox-tech] RHL 7 and kernel 2.4.0 woes
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [vox-tech] RHL 7 and kernel 2.4.0 woes




--- Deja User <unix_admin@my-deja.com> wrote:
> There may be an easy answer awaiting Jan, but it
> goes to show... it ain't necessarily as easy as it
> looks, folks. ("These hackers are trained
> professionals ladies and gentlemen! Please try this
> at home!")
> I've read the GPL2 a few times these last weeks
> (essentially "no warranty whatsoever"). So the
> community is covered... but please, someone call a
> doctor or an ambulance or something for Jan! Where
> is our hero with the white hat when the damsel in
> distress is lying across the railroad tracks with
> the train fast approaching?

Here's my scoop:

Last night I was trying to compile with old modutils
(not 2.4.0 as recommended), old e2fsprogs (not 1.19 as
recommended), and old ppp (not 2.4.0 as recommended). 
So I upgraded all those, and tried again.  

And got a bit farther.  Makes and such were done to
completion and without terrible errors.  So, I
modified lilo.conf, ran lilo (in the make install
script), and crossed my fingers.  Anyhow, when I tried
to boot, the messages went somewhat like:

Uncompressing linux.......
Ok booting the kernel
TCP Stuff....
IPv4 blah blah
[more lines of stuff]
kernel panic: VFS: unable to mount root file system:
/dev/hda2 bad parameter

Or some such.  It's roughly 3:30 am, and I don't
remember the exact messages, but it hangs there.  I
have to reboot and use the old kernel :(.  It's weird,
cause it begins to load some stuff, but when it tries
to find the root file system, it hangs.  In the docs
it says to use a line in lilo.conf to pass the boot
partition to the kernel so I added the line:

image=vmlinux-2.4.1
        label=linux241
        append = "root=/dev/hda2"

This produced the exact same results.

Anyhoo, if I find out anything more, I'll let the list
know, but if anyone has a clue, I would be happy to
hear :). 

Thanks much.

Jan

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/


LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.