l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
August 5: Social gathering
Next Installfest:
TBD
Latest News:
Jul. 4: July, August and September: Security, Photography and Programming for Kids
Page last updated:
2001 Dec 30 16:59

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] [rgscofield@ucdavis.edu: Help Please]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] [rgscofield@ucdavis.edu: Help Please]


  • Subject: Re: [vox-tech] [rgscofield@ucdavis.edu: Help Please]
  • From: Mark Kim <mkkim@ucdavis.MAPSedu>
  • Date: Mon, 04 Dec 2000 14:05:50 -0800
  • References: 20001204131551.D22780@dirac.org

How in the world did you lose rpmrc?  A copy from the ECE department RH
system is attached.

-Mark

On Mon, 4 Dec 2000 p@dirac.org wrote:

> you would get a much better reply from the group.
> 
> 180 minds work better than 1, so i'm forwarding this to the vox-tech.
> besides, then i would have to ask you for a lert donation.   ;)
> 
> 
> if i were in your shoes...
> 
> i'd find someone with the same operating system, ask them to tar up the
> relevant directory and send it to me, and hope for the best.
> 
> _if_ /usr/lib/rpm doesn't contain specific information about your system
> (ie, which rpms are on your particular machine), then i don't see why this
> wouldn't work.   however, if it does contain specific information about your
> system, then you're in very serious trouble.   i don't remember where rpm
> keeps its system info.
> 
> have you tried the --force option with rpm to install rpm.rpm?
> 
> another course of action would be to use rpm2cpio, convert the rpm to a cpio
> archive.  then unarchive the cpio file.  i have to figure this damned
> command every time i use it.   i keep wanting to use
> 
>       cpio -i mycpio.cpio --no-absolute-filenames
> 
> but that doesn't work.  it wants some other option which i can never
> remember.  usually takes me 15-30 minutes everytime i do this.   anyway,
> once you turn the rpm -> cpio -> a bunch of files, you can move the files
> where they belong.  so for instance, ./usr/lib/rpm should be moved to
> /usr/lib/rpm.  or whatever is missing...
> 
> these are some ideas.  maybe someone will come up with a better one, but at
> least it gives you a starting point.
> 
> pete
> 
> 
> 
> > -- Forwarded message from "Robert G. Scofield" <rgscofield@ucdavis.edu> -----
> > 
> > Date: Mon, 04 Dec 2000 12:52:41 -0800
> > From: "Robert G. Scofield" <rgscofield@ucdavis.edu>
> > X-Mailer: Mozilla 4.7 [en] (X11; U; Linux 2.2.12-20 i686)
> > Subject: Help Please
> > 
> > Pete,
> >
> > I've really messed up.  I've got a big problem on my hands.  I
> > downloaded a new update for rpm.  rpm has apparently changed, and so
> > there's an update for it.  When I tried to install the rpm for the rpm
> > update I got an error message saying that an rpm directory could not be
> > removed because it was not empty.  I responded to this by rm -r for the
> > relevant directory.  That was a big mistake, because now when I try to
> > install the new rpm for the rpm update I get this message:  "unable to
> > open /usr/lib/rpm/rpmrc no such file or directory."
> > 
> > I then got out my Red Hat cd and and tried to re-install the rpm for the
> > original version of rpm.  Of course that won't work either because I get
> > the same error message.  The bottom line is that I cannot now install
> > any rpms.  What can I do?  Do I try to find someone else who's running
> > Red Hat 6.1 and ask for a copy of /usr/lib/rpm/rpmrc?
> > 
> > Do I upgrade to Red Hat 6.2?  If so, will it upgrade a file that is not
> > there, such as /usr/lib/rpm/rpmrc?
> > 
> > Thanks.
> > 
> > Bob
> > 
> > --
> > Robert G. Scofield
> > rgscofield@ucdavis.edu
> 

---
Mark K. Kim
http://www.cbreak.org/mark/
PGP key available upon request.


LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.