l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
April 21: Google Glass
Next Installfest:
TBD
Latest News:
Mar. 18: Google Glass at LUGOD's April meeting
Page last updated:
2001 Dec 30 16:57

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Cable Modem and Ethernet Card
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Cable Modem and Ethernet Card


  • Subject: Re: [vox-tech] Cable Modem and Ethernet Card
  • From: "Jay Strauss" <jstrausMAPSs@bazillion.com>
  • Date: Tue, 03 Oct 2000 19:34:40 -0700
  • References: Pine.LNX.4.21.0010031551170.20440-100000@satan

1) Get a new card - I use RH but the D-link 100... works well and is detected as
hardware and configures at boot (cheap and easy...Which brings to mind another
topic but I digress).

2) I did get my linksys (model: something like le100tx) working, I never could
get it to configure on boot.  I remember (I did this a while ago) that I needed
to get and compile pci-scan.c (getting the pciscan.h file too) - I found the
notes I took:

Compiled pci-scan.c
# gcc -DMODULE -D__KERNEL__ -O6 -c pci-scan.c
Compiled tulip.c
# gcc -DMODULE -D__KERNEL__ -O6 -c tulip.c
Test/install module
# insmod pci-scan.o
Test/install module
# insmod tulip.o
copy/install modules in module library
# install -m 644 pci-scan.o /lib/modules/2.2.14-5.0/net/
copy/install modules in module library
# install -m 644 tulip.o /lib/modules/2.2.14-5.0/net/
update the module database
# depmod -a
Editted /etc/modules.conf
added line: alias eth1 tulip

Then I had to run a script on boot to configure it like:
insmod /lib/modules/2.2.14-5.0/net/tulip.o
ifconfig....

Pete, you want to add to this??

Jay Strauss
jstrauss@bazillion.com
(h) 773.935.5326
(c) 312.617.0264

----- Original Message -----
From: "Peter Jay Salzman" <p@belial.ucdavis.edu>
To: <vox-tech@lists.lugod.org>
Sent: Tuesday, October 03, 2000 5:52 PM
Subject: Re: [vox-tech] Cable Modem and Ethernet Card


> 2 suggestions
>
> 1. have you looked up your card in the ethernet howto?  if it's there, that
> will give a definitive answer for sure.
>
> 2. there are actually 2 tulip modules.  one is called decchip tulip, and the
> other is generic tulip.  have you tried both?
>
> pete
>
> On Tue, 3 Oct 2000, Roland Minden wrote:
>
> > I was fealling like a real dunderhead, but LibraNet Technical Support has
> > had problems with the same thing. I have a Linksys Etherfast 10/100 Card. It
> > runs on the tulip chip. I have not been able to get it working on Debian
> > (Libranet is Debian with a few goodies). I have therefore not been able to
> > get live with my Linux Box. Has anyone used this Ethernet Card? What simple
> > thing am I missing. LibraNet has suggested I compile a newer version of
> > tulip.c not a big deal, but I have tried this before calling LibraNet. I may
> > have done something wrong, but I am pretty sure I did it correctly. I have
> > tried it as a compilation to the kernal and as a module. I am getting a card
> > unkown when I use lspci (I am not sure if that is the command, but I think
> > that is correct) actully lspci > /tmp/lspci.
> > This card came out of the box and it works with the Linksys driver for M$ Wn
> > 98. I am wondering if I should get another NIC or keep working on this one.
> > I am looking for suggestions. It is a PCI card.
>
>


LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.